zoukankan      html  css  js  c++  java
  • POJ 2054 Color a Tree解题报告

    题干
    Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the “root” of the tree, and there is a unique path from the root to each of the other nodes.
    Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, …, N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try.
    Each node has a “coloring cost factor”, Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi.
    For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33.
    Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.
    Input
    The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed.

    A test case of N = 0 and R = 0 indicates the end of input, and should not be processed.
    Output
    For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.
    Sample Input
    5 1
    1 2 1 2 4
    1 2
    1 3
    2 4
    3 5
    0 0
    Sample Output
    33

    题意,每个结点都有一个粉刷权值,第几个访问所消耗的代价就是权值乘以第几次访问!贪心,怎么贪?经历了觉得网站有问题以及换网站。
    在这里插入图片描述
    在这里插入图片描述
    去CSDN去看了看大牛写的博客,解题报告,不太明白。慢慢的摸索,抄代码,修改,自己敲。比较 权值应该等于真实权值➗合并节点数,相当于这个节点由N个等权值结点组成。权值就是刷它之前所消耗的代价,这样理解起来就不是很难。
    这样一来就是不断从大到小归并权值,直到root树根。
    便有了如下贪心准则:
    1.要使代价小,必须尽早访问权值较大的结点。
    2.要访问该结点,必须先访问他的父节点。
    3.访问一个节结后,从该节点的父结点访问该节点的子节点不需要 是消耗代价。
    也就是说访问了最大值的父节点就因该立刻访问最大直结点。便可以找最大值节点开始访问。
    代码如下

    #include<iostream>
    #include<queue>
    #include<cstdio>
    #include<algorithm>
    #include<cmath>
    #include<map>
    #include<cstring>
    using namespace std;
    bool myfind();
    struct object
    {
        int grade,fa,tim;
        double weight;
    }ob[1005];
    int branch,root,flag,fa,kid,tem,mx=0;
    int main()
    {
        ios::sync_with_stdio(false);
        while(cin>>branch>>root)
        {
            tem=0;
            memset(ob,0,sizeof(object)*1005);
            if(branch==root&&branch==0) break;
            for(int i=1;i<=branch;i++) cin>>ob[i].grade,ob[i].tim=1,ob[i].weight=ob[i].grade;
            for(int i=1;i<branch;i++)
            {
                cin>>fa>>kid;
                ob[kid].fa=fa;
            }
            while(myfind())
            {
                ob[ob[mx].fa].grade=ob[ob[mx].fa].grade+ob[mx].grade;
                tem=tem+ob[ob[mx].fa].tim*ob[mx].grade;
                ob[ob[mx].fa].tim=ob[ob[mx].fa].tim+ob[mx].tim;
                //cout<<tem<<endl;
                ob[mx].weight=0;
                for(int i=1;i<=branch;i++)
                {
                    if(ob[i].fa==mx) ob[i].fa=ob[mx].fa;
                }
                ob[ob[mx].fa].weight = 1.0*ob[ob[mx].fa].grade/ob[ob[mx].fa].tim ;
            }
            tem=tem+ob[root].grade;
            cout<<tem+1<<endl;
        }
        return 0;
    }
    bool myfind()
    {
        double max=0;
        flag=0;
        for(int i=1;i<=branch;i++)
        {
            if(i==root) continue;
            if(ob[i].weight>max)
            {
                max=ob[i].weight;
                mx=i;
                flag=1;
                    //cout<<i<<endl;
            }
    
        }
        return flag;
    }
    
  • 相关阅读:
    spring security 学习资料
    设计模式,学习资料
    知名博主
    shiro 学习资料
    nuxt 中使用 koa-session
    koa-session 知识点
    MySQL 中的默认数据库介绍
    JUnit 学习资料
    027_git添加多账号设置
    023_supervisorctl管理服务注意事项
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12799057.html
Copyright © 2011-2022 走看看