zoukankan      html  css  js  c++  java
  • The 15th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple

    King of Karaoke

    Time Limit: 1 Second      Memory Limit: 65536 KB

    It's Karaoke time! DreamGrid is performing the song Powder Snow in the game King of Karaoke. The song performed by DreamGrid can be considered as an integer sequence , and the standard version of the song can be considered as another integer sequence . The score is the number of integers  satisfying  and .

    As a good tuner, DreamGrid can choose an integer  (can be positive, 0, or negative) as his tune and add  to every element in . Can you help him maximize his score by choosing a proper tune?

    Input

    There are multiple test cases. The first line of the input contains an integer  (about 100), indicating the number of test cases. For each test case:

    The first line contains one integer  (), indicating the length of the sequences  and .

    The second line contains  integers  (), indicating the song performed by DreamGrid.

    The third line contains  integers  (), indicating the standard version of the song.

    It's guaranteed that at most 5 test cases have .

    Output

    For each test case output one line containing one integer, indicating the maximum possible score.

    Sample Input

    2
    4
    1 2 3 4
    2 3 4 6
    5
    -5 -4 -3 -2 -1
    5 4 3 2 1
    

    Sample Output

    3
    1
    

    Hint

    For the first sample test case, DreamGrid can choose  and changes  to .

    For the second sample test case, no matter which  DreamGrid chooses, he can only get at most 1 match.

    原题地址:http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5753

    题意:给你两个数组A,B,问你A数组所有元素同时加一个数或减一个数或不变之后与B数组相同的最大个数;

    思路:因为数组A加的数是相同的所以A数组变化之后差值个数还是一样,所以直接计算A数组和B数组之间的差值最多的个数就行,因为可能有负数,所以用map又轻松又简单,map真是个好东西

    代码:

    #include<bits/stdc++.h>
    using namespace std;
    
    int a[5000000];
    int b[5000000];
    int main()
    {
        std::ios::sync_with_stdio(false);
        int t;
        cin>>t;
        while(t--){
            map<int,int>mp;
            int n;
            cin>>n;
            for(int i=0;i<n;i++){
                    cin>>a[i];
            }
            for(int i=0;i<n;i++){
                    cin>>b[i];
            }
            for(int i=0;i<n;i++){
                    mp[a[i]-b[i]]++;
            }
            int maxn=0;
            map<int,int>::iterator it;
            for(it=mp.begin();it!=mp.end();it++){
                    if(it->second>maxn){
                            maxn=it->second;
                    }
            }
            cout<<maxn<<endl;
        }
        return 0;
    }
  • 相关阅读:
    haproxy+keepalived配置haproxy反向代理的高可用
    正则表达式
    logstash 中multiline插件的用法
    logtash 接收多配置文件
    Debian 8 升级到 9 Debian 9 How to upgrade Debian 8 Jessie to Debian 9 Stretch
    YOLO object detection with OpenCV
    快速 图片颜色转换迁移 Color Transfer Opencv + Python
    对抗网络GAN的应用实例
    nvflash 报错解决
    卷积神经网络(CNN)在语音识别中的应用
  • 原文地址:https://www.cnblogs.com/luowentao/p/8972740.html
Copyright © 2011-2022 走看看