zoukankan      html  css  js  c++  java
  • Java练习 SDUT-1959_简单枚举类型——植物与颜色

    简单枚举类型——植物与颜色

    Time Limit: 1000 ms Memory Limit: 65536 KiB

    Problem Description

    请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
    Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.

    Input

    输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。

    Output

    输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.

    Sample Input

    blue
    yellow
    purple

    Sample Output

    Bluebells are blue.
    Sunflower are yellow.
    I don't know about the color purple.

    Hint

    请用枚举类型实现。

    Source

    lxh

    枚举,由于Java枚举跟C有很大不同,所以打算试试,有很多不会的地方,列如枚举类的使用,try catch(Exception e)不会。
    后期会回来补充。
    借鉴:

    import java.util.*;
    
    enum Color//枚举类
    {
    	red("Rose","red"),
    	orange("Poppies","orange"),
    	yellow("Sunflower","yellow"),
    	green("Grass","green"),
    	blue("Bluebells","blue"),
    	violet("Violets","violet");
    	String color,name;
    	Color(String name,String color)
    	{
    		this.name = name;
    		this.color = color;
    	}
    	public String getcolor()
    	{
    		return name+" are "+color+".";
    	}
    }
    
    public class Main {
        public static void main(String[] args) {
            Scanner cin = new Scanner(System.in);
            String name;
            while(cin.hasNext())
            {
            	name = cin.next();
            	try
            	{
            		Color c = Color.valueOf(name);
            		System.out.println(c.getcolor());
            	}
            	catch(Exception e)
            	{
            		System.out.println("I don't know about the color "+name+".");
            	}
            }
            cin.close();
        }
    
    }
    
  • 相关阅读:
    JavaScript节点属性
    main函数的参数
    CGI
    open()函数 linux中open函数使用
    海伦公式
    C语言字符串操作函数
    makefile(一)
    makefile
    第一天
    时间小憩
  • 原文地址:https://www.cnblogs.com/luoxiaoyi/p/9712205.html
Copyright © 2011-2022 走看看