zoukankan      html  css  js  c++  java
  • HDU-1029_Ignatius and the Princess IV

    Ignatius and the Princess IV

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)

    Problem Description

    "OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

    "I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

    "But what is the characteristic of the special integer?" Ignatius asks.

    "The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

    Can you find the special integer for Ignatius?

    Input

    The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

    Output

    For each test case, you have to output only one line which contains the special number you have found.

    Sample Input

    5
    1 3 2 3 3
    11
    1 1 1 1 1 5 5 5 5 5 5
    7
    1 1 1 1 1 1 1

    Sample Output

    3
    5
    1

    Author

    Ignatius.L

    题意:给奇数个数字,找一个至少出现了 (n+1)/2次的特殊数字。
    题解:一道水题,用好 (n+1)/2就可以,看代码。~(其实只要排一次序,然后直接输出中间那个数就可以)~

    #include <iostream>
    #include <cstdio>
    
    using namespace std;
    
    int main()
    {
        int n,num,a,x,i;
        while(scanf("%d",&n)!=EOF)
        {
            num = 0;
            for(i=0;i<n;i++)
            {
                scanf("%d",&a);
                if(!num)
                {
                    num = 1;
                    x = a;
                }
                else
                {
                    if(a==x)
                        num++;
                    else
                        num--;
                }
            }
            cout<<x<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    《网络攻防实践》6.0
    《网络攻防实践》5.0
    Docker 本地镜像发布到阿里云(完结篇)
    Vue 实战-9 Vue公共js功能函数的封装和使用
    Vue 实战-8 单独运行测试.js文件
    Docker 常用安装
    DockerFile 解析及案例
    Docker 容器数据卷
    Docker 镜像原理
    多字段模糊匹配 -->搜索功能(mysql原生语句实现)
  • 原文地址:https://www.cnblogs.com/luoxiaoyi/p/9719211.html
Copyright © 2011-2022 走看看