zoukankan      html  css  js  c++  java
  • Java练习 SDUT-1140_面向对象程序设计上机练习一(函数重载)

    面向对象程序设计上机练习一(函数重载)

    Time Limit: 1000 ms Memory Limit: 65536 KiB

    Problem Description

    利用数组和函数重载求5个数最大值(分别考虑整数、单精度、长整数的情况)。

    Input

    分别输入5个int型整数、5个float 型实数、5个long型正整数。

    Output

    分别输出5个int型整数的最大值、5个float 型实数的最大值、5个long型正整数的最大值。

    Sample Input

    11 22 666 44 55
    11.11 22.22 33.33 888.88 55.55
    1234567 222222 333333 444444 555555

    Sample Output

    666
    888.88
    1234567

    Hint

    Source

    zlh

    import java.util.*;
    
    public class Main
    {
    	public static void main(String[] args)
    	{
    		Scanner cin = new Scanner(System.in);
    		int a1,b1,c1,d1,e1,m1;
    		float a2,b2,c2,d2,e2,m2;
    		long a3,b3,c3,d3,e3,m3;
    		a1 = cin.nextInt();
    		b1 = cin.nextInt();
    		c1 = cin.nextInt();
    		d1 = cin.nextInt();
    		e1 = cin.nextInt();
    		m1 = max(a1,b1,c1,d1,e1);
    		a2 = cin.nextFloat();
    		b2 = cin.nextFloat();
    		c2 = cin.nextFloat();
    		d2 = cin.nextFloat();
    		e2 = cin.nextFloat();
    		m2 = max(a2,b2,c2,d2,e2);
    		a3 = cin.nextLong();
    		b3 = cin.nextLong();
    		c3 = cin.nextLong();
    		d3 = cin.nextLong();
    		e3 = cin.nextLong();
    		m3 = max(a3,b3,c3,d3,e3);
    		System.out.println(m1+"
    "+m2+"
    "+m3);
    		cin.close();
    	}
    	static int max(int a,int b,int c,int d,int e)
    	{
    		int m;
    		m  = a;
    		if(m<b)
    			m = b;
    		if(m<c)
    			m = c;
    		if(m<d)
    			m = d;
    		if(m<e)
    			m = e;
    		return m;
    	}
    	static float max(float a,float b,float c,float d,float e)
    	{
    		float m;
    		m  = a;
    		if(m<b)
    			m = b;
    		if(m<c)
    			m = c;
    		if(m<d)
    			m = d;
    		if(m<e)
    			m = e;
    		return m;
    	}
    	static long max(long a,long b,long c,long d,long e)
    	{
    		long m;
    		m  = a;
    		if(m<b)
    			m = b;
    		if(m<c)
    			m = c;
    		if(m<d)
    			m = d;
    		if(m<e)
    			m = e;
    		return m;
    	}
    }
    
  • 相关阅读:
    Shader-另类实现
    Unity3d- 资源
    我不快乐
    陷入了一个NGUI自适应的一个坑
    ngui 自适应
    NGUI的数据绑定
    我已经很努力,但是依旧写给自己
    那些奇葩的叫法
    C#修改类模板
    开启Unity3D之旅
  • 原文地址:https://www.cnblogs.com/luoxiaoyi/p/9795870.html
Copyright © 2011-2022 走看看