zoukankan      html  css  js  c++  java
  • poj2039

    To and Fro
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 8052   Accepted: 5367

    Description

    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There’s no place like home on a snowy night" and there are five columns, Mo would write down 
    t o i o y
    
    h p k n n
    
    e l e a i
    
    r a h s g
    
    e c o n h
    
    s e m o t
    
    n l e w x

    Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character "x" to pad the message out to make a rectangle, although he could have used any letter. 

    Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as 

    toioynnkpheleaigshareconhtomesnlewx 

    Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one. 

    Input

    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

    Output

    Each input set should generate one line of output, giving the original plaintext message, with no spaces.

    Sample Input

    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0

    Sample Output

    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab

    #include<stdio.h>

    #include<string.h>

    int main()

    {
     
    char a[200];
     
    int n,i,j,l,t,p;

     while(scanf("%d",&n)!=EOF&&n!=0)

     {
        
    getchar();
     
     gets(a);
     
     l=strlen(a);
      
    t=l/n;
      
    for(i=0;i<n;i++)
     
     {
        
      for(j=1;j<=t;j++)
      
        if(j%2==0)
       
       printf("%c",a[j*n-i-1]);
       
       else
         
         printf("%c",a[(j-1)*n+i]);
     
     }
     
     printf(" ");

     }

     return 0;

    }
  • 相关阅读:
    SQL手工注入方法
    Python + Django 网站平台搭建之- 初识 (一)
    最新版Idea2019.3.4/2020.1完美破解
    使用 Guns 自动生成 SpringBoot + LayUI 的后台管理系统
    SpringBoot+Layui后台管理系统
    国内Maven中央仓库推荐 速度最快最好的Maven仓
    git 下载失败 中断了 继续下 怎么配置参数
    mysql 创建与授权
    jboot-admin
    自动生文器
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3268154.html
Copyright © 2011-2022 走看看