zoukankan      html  css  js  c++  java
  • hdu1517

    A Multiplication Game

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2967    Accepted Submission(s): 1704


    Problem Description
    Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
     
    Input
    Each line of input contains one integer number n.
     
    Output
    For each line of input output one line either

    Stan wins.

    or

    Ollie wins.

    assuming that both of them play perfectly.
     
    Sample Input
    162
    17
    34012226
     
    Sample Output
    Stan wins.
    Ollie wins.
    Stan wins.
     
    分析:
    如果输入是 2 ~ 9 ,因为Stan 是先手,所以Stan 必胜
    如果输入是 10~18 ,因为Ollie 是后手,不管第一次Stan 乘的是什么,Stan肯定在 2 ~ 9 之间,
    如果Stan乘以 2 ,那么Ollie就乘以 9 ,就到18了,如果Stan乘以 9 ,
    那么Ollie乘以大于1的数都都能超过 10 ~ 18 中的任何一个数。Ollie 必胜
    如果输入是 19 ~ 162,那么这个范围是 Stan 的必胜态
    如果输入是 163 ~ 324 ,这是Ollie的必胜态
    ............
    必胜态是对称的!!!
    如果"我方"首先给出了一个在N不断除18后的得到不足18的
    数M,"我方"就可以取得胜利,然而双方都很聪明,所以这样胜负就决定于N了,如果N不断除
    18后的得到不足18的数M,如果1<M<=9则先手胜利,即Stan wins.如果9<M<=18
    则后手胜利.

    也就是说,18是一个循环。

    #include<stdio.h>
    int main()
    {
    double n;
    while(scanf("%lf",&n)!=EOF)
    {
    while(n>18)
    n/=18;
    if(n<=9)
    printf("Stan wins. ");
    else
    printf("Ollie wins. ");
    }
    return 0;
    }

     
  • 相关阅读:
    课后作业 学号15100457
    开学第一课
    20180320作业2:进行代码复审训练
    20180320作业1:源代码管理工具调查
    软工作业PSP与单元测试训练
    构建之法 完成教材第一章P18第4题
    第一天上课 创建博客
    进行代码复审训练
    源代码管理工具调查
    软工作业PSP与单元测试训练
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3280903.html
Copyright © 2011-2022 走看看