zoukankan      html  css  js  c++  java
  • hdu1525&&poj2348

    Euclid's Game

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
    Total Submission(s) : 0   Accepted Submission(s) : 0
    Problem Description
    Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
             25 7
    
    11 7
    4 7
    4 3
    1 3
    1 0

    an Stan wins.
     
    Input
    The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
     
    Output
    For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
     
    Sample Input
    34 12
    15 24
    0 0
     
    Sample Output
    Stan wins
    Ollie wins
     
     
    方法一:
    找规律,谁先遇到关键态,谁就获胜,关键态为:a>=2*b;

    #include<iostream>
    #include<algorithm>
    #include<stdio.h>
    using namespace std;
    int main()
    {
    int a,b;
    while(~scanf("%d%d",&a,&b)&&(a||b))
    {
    if(a<b)swap(a,b);
    int flag=1;
    while(1)
    {
    if(a==b||a/b>=2)
    break;
    a=a-b;
    swap(a,b);
    flag=!flag;
    }
    if(flag)
    printf("Stan wins ");
    else
    printf("Ollie wins ");
    }
    return 0;
    }

    方法二:

    给两堆石子(题目中是数,配合一下上文这里说石子),两人依次取石子,规则是:
    每次从石子数较多的那堆取(两堆石子数目相等时任选一堆),取的数目只能为石子少的
    那一堆的正整数倍。最后取完一堆石子者胜。问给定情况下先手胜负情况。
    多列几项就会发现一个熟悉的身影:斐波拉契数列。最后的结论是如果两个数相等,或者两数之比大于斐
    波拉契数列相邻两项之比的极限((sqrt(5)+1)/2),则先手胜,否则后手胜。

    #include<stdio.h>
    #include <math.h>
    int main()
    {
    int a,b;
    double c=(1.0+sqrt(5.0))/2.0;
    while(scanf("%d%d",&a,&b)!=EOF && (a ||b))
    {
    if(a==b)
    {
    printf("Stan wins ");
    continue;
    }
    if(a<b)
    {
    a=a^b;
    b=a^b;
    a=a^b;
    }
    if((double)a/b>c)
    printf("Stan wins ");
    else
    printf("Ollie wins ");
    }
    }

  • 相关阅读:
    Wepy 格式化和语法高亮(vscode)
    TypeError: Cannot read property '_wrapper' of undefined
    Vue 自定义事件传参
    Uncaught (in promise) undefined
    微信小程序 获取用户昵称、头像
    微信小程序scroll-view去除滚动条
    微信小程序从子页面退回父页面时的数据传递 wx.navigateBack()
    wx: wx.showModal 回调函数中调用自定义方法
    c#后端 小程序上传图片
    小程序配置,通用域名配置文件
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3281158.html
Copyright © 2011-2022 走看看