zoukankan      html  css  js  c++  java
  • PAT Basic 1032

    1032 挖掘机技术哪家强 (20 分)

    为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

    输入格式:

    输入在第 1 行给出不超过 105​​ 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

    输出格式:

    在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

    输入样例:

    6
    3 65
    2 80
    1 100
    2 70
    3 40
    3 0
    

    输出样例:

    2 150


    注意红色标记,想当然地认为了循环范围,实际可以取值到n
    数组范围也应当定义到a[100001]
    #define _CRT_SECURE_NO_WARNINGS
    #include<iostream>
    #include <vector>
    #include<algorithm>
    #include<string>
    #include<string.h>
    #include<math.h>
    #define max 100001
    #define debug 0
    using namespace std;

    int main() {
    #if debug
        freopen("in.txt", "r", stdin);
    #endif

        int a[max] = {0}, n = 0, temp = 0, score;
        cin >> n;
        for (int i = 0; i < n; i++)
        {
            cin >> temp>>score;
            a[temp] += score;
        }
        int ma = 0;
        for (int i = 1; i <=n; i++)
        {
            if (a[ma] < a[i])
            {
                ma = i;
            }
        }
        cout << ma << ' ' << a[ma];


    #if debug
        freopen("CON", "r", stdin);
    #endif
        return 0;
    }
  • 相关阅读:
    SpringMVC(二)
    SpringMVC(一)
    Mybatis之mapper.xml配置文件中的#{}和${}
    Mybatis(二)
    Mybatis(一)
    Linux部署项目
    BOS物流项目第十三天
    Failed to read schema document 'http://www.springframework.org/schema/beans/spring-beans.xsd'
    景点API支持查询携程旅游门票景点详情
    Html引入百度富文本编辑器ueditor及自定义工具栏
  • 原文地址:https://www.cnblogs.com/lxzbky/p/10507431.html
Copyright © 2011-2022 走看看