zoukankan      html  css  js  c++  java
  • luogu P2871 [USACO07DEC]手链Charm Bracelet

    题目描述

    Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

    Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

    有N件物品和一个容量为V的背包。第i件物品的重量是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。

    输入输出格式

    输入格式:
    • Line 1: Two space-separated integers: N and M

    • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
    输出格式:
    • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

    输入输出样例

    输入样例#1:
    4 6
    1 4
    2 6
    3 12
    2 7
    输出样例#1:
    23

    01背包:
    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    
    using namespace std;
    
    int n,m;
    int f[12880];
    int main()
    {
        int i,j,c,w;
        scanf("%d%d",&n,&m); 
        for (i=1; i<=n; ++i)
        {
            scanf("%d%d",&c,&w);
            for (j=m; j>=c; --j)
                f[j]=max(f[j],f[j-c]+w);
        }
        printf("%d",f[m]);
    }
    

      

  • 相关阅读:
    主线程MainThread与渲染线程RenderThread
    杀死进程的几种方式
    Android App的设计架构:MVC,MVP,MVVM与架构经验谈
    动画完全解析(二):补间动画原理及自定义动画
    SublimeText教程
    JqGrid自定义的列
    js 除法 取整
    js日期字符串增加天数的函数
    Oracle中的rownum和rowid
    jQuery判断对象是否是函数
  • 原文地址:https://www.cnblogs.com/lyqlyq/p/7207388.html
Copyright © 2011-2022 走看看