zoukankan      html  css  js  c++  java
  • P2925 [USACO08DEC]干草出售Hay For Sale

    题目描述

    Farmer John suffered a terrible loss when giant Australian cockroaches ate the entirety of his hay inventory, leaving him with nothing to feed the cows. He hitched up his wagon with capacity C (1 <= C <= 50,000) cubic units and sauntered over to Farmer Don's to get some hay before the cows miss a meal.

    Farmer Don had a wide variety of H (1 <= H <= 5,000) hay bales for sale, each with its own volume (1 <= V_i <= C). Bales of hay, you know, are somewhat flexible and can be jammed into the oddest of spaces in a wagon.

    FJ carefully evaluates the volumes so that he can figure out the largest amount of hay he can purchase for his cows.

    Given the volume constraint and a list of bales to buy, what is the greatest volume of hay FJ can purchase? He can't purchase partial bales, of course. Each input line (after the first) lists a single bale FJ can buy.

    约翰遭受了重大的损失:蟑螂吃掉了他所有的干草,留下一群饥饿的牛.他乘着容量为C(1≤C≤50000)个单位的马车,去顿因家买一些干草. 顿因有H(1≤H≤5000)包干草,每一包都有它的体积Vi(l≤Vi≤C).约翰只能整包购买,

    他最多可以运回多少体积的干草呢?

    输入输出格式

    输入格式:
    • Line 1: Two space-separated integers: C and H

    • Lines 2..H+1: Each line describes the volume of a single bale: V_i
    输出格式:
    • Line 1: A single integer which is the greatest volume of hay FJ can purchase given the list of bales for sale and constraints.

    输入输出样例

    输入样例#1:
    7 3 
    2 
    6 
    5 
    
    输出样例#1:
    7 
    

    说明

    The wagon holds 7 volumetric units; three bales are offered for sale with volumes of 2, 6, and 5 units, respectively.

    Buying the two smaller bales fills the wagon.

    竟然超时:

    #include<iostream>
    #include<cstdio>
    
    using namespace std;
    
    int f[50009],v[5009],n,m;
    
    int main()
    {
    	scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
    		scanf("%d",&v[i]);
        for(int i=1;i<=m;i++)
            for(int j=n;j>=v[i];j--)
                if(f[j]<f[j-v[i]]+v[i])
    				f[j]=f[j-v[i]]+v[i];
    
        printf("%d",f[n]);
        return 0;
    }
    

      

    #include<iostream>
    
    using namespace std;
    int c,h;//c容量 h种情况 
    int f[50005];
    int v[50005];
    
    int main()
    {
        cin >> c >> h;
        for(int i = 1;i <= h;i++)
            cin >> v[i];
        for(int i = 1;i <= h;i++)
    	{
            for(int a = c;a >= v[i];a--)
    		{
                if(f[a] == a)
                    continue;  //此时f[a]已经取到最大值 就不用再对f[a]进行更新 
                if(f[a - v[i]] + v[i] > f[a])
                    f[a] = f[a - v[i]] + v[i];
            }
            if(f[c] == c)
    		{//判断是否已经能够装满c体积的干草
                cout << c;//能够装满
                return 0;//退出
            }
        }
        cout << f[c];
        return 0;
    }
    

      

  • 相关阅读:
    Linux下 printf 输出字符串的颜色
    ARM指令集详解(超详细!带实例!)
    试试代码框
    java web各种listener
    mysql 技术支持
    Tomcat 技术支持
    关于PreparedStatement.addBatch()方法
    JQuery banner 轮播
    Extjs 提示窗口
    如何删除JSP编译后的空行
  • 原文地址:https://www.cnblogs.com/lyqlyq/p/7207660.html
Copyright © 2011-2022 走看看