zoukankan      html  css  js  c++  java
  • Elevator

    /*Elevator
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

    Output
    Print the total time on a single line for each test case.

    Sample Input
    1 2
    3 2 3 1
    0
     

    Sample Output
    17
    41

    */
    #include<stdio.h>
    int main()
    {
        int test,i;
        while(~scanf("%d",&test),test!=0)
        {
            int a[110]={0};
            int sum=0;
            for(i=0;i<test;i++)
            scanf("%d",&a[i]);
            for(i=0;i<test-1;i++)//这一步推断是关键 。注意i<test-1
            {
                if(a[i+1]>a[i])
                sum+=(a[i+1]-a[i])*6;
                else
                sum+=(a[i]-a[i+1])*4;
            }
            printf("%d ",sum+a[0]*6+test*5);
        }
        return 0;
    }
           
           
       

  • 相关阅读:
    windows10(64位)Anaconda3+Python3.6搭建Tensorflow(cpu版本)及keras
    Windows10下安装pytorch并导入pycharm
    应用程序无法正常启动0xc000007b解决
    Clion安装配置
    Android Studio安装&&安装bug
    VMWARE虚拟机安装64位系统此主机支持IntelVTx 但IntelVTx处于禁用状态
    A. Text Volume
    1001 数组中和等于K的数对
    11100
    Seek the Name, Seek the Fame
  • 原文地址:https://www.cnblogs.com/lytwajue/p/6943818.html
Copyright © 2011-2022 走看看