zoukankan      html  css  js  c++  java
  • poj 1068 Parencodings(模拟)

    转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

    题目链接:http://poj.org/problem?

    id=1068

    
    

    Description

    Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
    q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
    q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

    Following is an example of the above encodings: 
    	S		(((()()())))
    
    	P-sequence	    4 5 6666
    
    	W-sequence	    1 1 1456
    
    

    Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

    Input

    The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

    Output

    The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

    Sample Input

    2
    6
    4 5 6 6 6 6
    9 
    4 6 6 6 6 8 9 9 9
    

    Sample Output

    1 1 1 4 5 6
    1 1 2 4 5 1 1 3 9

    题意:

    一组括号 (((( ) ( ) ( ) ) ) )

    有两种描写叙述方法:

    P方法:4 5 6 6 6 6 - 每个‘)’前,有几个‘(’

    W方法:1 1 1 4 5 6 - 每个‘)‘的前面第几个(注意是从当前位置往前面数)’(‘是跟它匹配的

    要求是依据P求W

    思路:

    先依据P还原出括号的位置,在计算出W就可以。


    代码例如以下:

    #include <iostream>
    using namespace std;
    #include <cstring>
    #define N 117
    char s[10000];
    int n;
    int i, j, k, l;
    int p[N],w[N], flag[N];
    void WW()
    {
    	int x = 1;
    	int count = 0;
    	for(i = 1; i < l; i++)
    	{
    		if(s[i] == ')')
    		{
    			for(j = i-1; j >= 1; j--)
    			{
    				if(s[j] == '(')
    				count++;
    				if(flag[j] == 0 && s[j] == '(')
    				{
    					flag[j] = 1;
    					w[x++] = count;
    					break;
    				}
    			}
    			count = 0;
    		}
    	}
    }
    int main()
    {
    	int t;	
    	while(cin >> t)
    	{
    		while(t--)
    		{
    			memset(flag,0,sizeof(flag));
    			cin >> n;
    			k = 0, l = 1;
    			for(i = 1; i <= n; i++)
    			{
    				cin >> p[i];
    				for(j = 1; j <= p[i] - k; j++)
    				{
    					s[l++] = '(';
    				}
    				s[l++] = ')';
    				k = p[i];
    			}
    		//	cout<<s<<endl;
    			WW();
    			for(i = 1; i < n; i++)
    			{
    				cout<<w[i]<<' ';
    			}
    			cout<<w[n]<<endl;
    		}
    	}
    	return 0;
    }



  • 相关阅读:
    PetaLinux 生成 Zynq 操作系统
    单片机、微控制器和微处理器有什么区别
    嵌入式基础概念系列(1) —— GPIO
    学中杂记
    Spring学习笔记
    jdbc一点小笔记
    JSP学习
    Servlet学习的一些笔记
    接触Struts2的ModelDriven<>接口
    android-dialog的位置
  • 原文地址:https://www.cnblogs.com/lytwajue/p/7109670.html
Copyright © 2011-2022 走看看