zoukankan      html  css  js  c++  java
  • HDU 1014 Uniform Generator 题解

    找到规律之后本题就是水题了。只是找规律也不太easy的。证明这个规律成立更加不easy。

    本题就是求step和mod假设GCD(最大公约数位1)那么就是Good Choice,否则为Bad Choice

    为什么这个结论成立呢?

    由于当GCD(step, mod) == 1的时候。那么第一次得到序列:x0, x0 + step, x0 + step…… 那么mod之后,必定下一次反复出现比x0大的数必定是x0+1,为什么呢?

    由于(x0 + n*step) % mod。 且不须要考虑x0 % mod的值为多少,由于我们想知道第一次比x0大的数是多少,那么就看n*step%mod会是多少了。由于GCD(step, mod) == 1。那么n*step%mod必定是等于1。故此第一次反复出现比x0大的数必定是x0+1,那么第二次出现比x0大的数必定是x0+2。以此类推,就可得到必定会出现全部0到mod-1的数,然后才会反复出现x0.

    当GCD(step, mod) != 1的时候,能够推出肯定跨过某些数了。这里不推了。

    然后能够扩展这个结论。比方假设使用函数 x(n) = (x(n-1) * a + b)%mod;添加了乘法因子a。和步长b了;

    那么假设是Good Choice,就必定须要GCD(a, mod) == 1,并且GCD(b, mod) == 1;

    这里就偷懒不证明这个扩展结论了,并且证明这个结论须要用到线性模(Congruence)和乘法逆元的知识了。


    题目: 

    Problem Description
    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where '%' is the modulus operator. 

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 
     

    Input
    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
     

    Output
    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
     

    Sample Input
    3 5 15 20 63923 99999
     

    Sample Output
    3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice


    本题的代码是非常easy的:
    #include <stdio.h>
    
    inline int GCD(int a, int b)
    {
    	return b == 0? a : GCD(b, a % b);
    }
    
    int main()
    {
    	int step, mod;
    	while (scanf("%d %d", &step, &mod) != EOF)
    	{
    		printf("%10d%10d    ", step,mod);  
    		if(GCD(step, mod) == 1) printf("Good Choice
    
    ");  
    		else printf("Bad Choice
    
    ");  
    	}
    	return 0;
    }


  • 相关阅读:
    linux 11201(11203) ASM RAC 安装
    [学习笔记]多项式对数函数
    linux 10201 ASM RAC 安装+升级到10205
    tar
    [学习笔记]多项式开根
    gzip
    小朋友和二叉树
    zip
    bzoj5016 一个简单的询问
    unzip
  • 原文地址:https://www.cnblogs.com/lytwajue/p/7248605.html
Copyright © 2011-2022 走看看