zoukankan      html  css  js  c++  java
  • POJ1163(DP,Water)

    1163:The Triangle

    时间限制:

    1000ms

    内存限制:

    65536kB

    描述

    7
    3   8
    8   1   0
    2   7   4   4
    4   5   2   6   5

    (Figure 1)


    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

    输入

    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rowsin the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

    输出

    Your program is to write to standard output. The highest sum is written as an integer.

    样例输入

    5

    7

    3 8

    8 1 0

    2 7 4 4

    4 5 2 6 5

    样例输出

    30

    #include"iostream"
    using namespace std;
    int max(int x,int y)
    {
     if(x>y)
      return x;
     else
      return y;
    }
    int main()
    {
     int row;
     cin>>row;
     int** matrix=new int*[row+1];
     for(int i=0;i<row+1;i++)
      matrix[i]=new int[row+1];
     for(int i=1;i<=row;i++)
      for(int j=1;j<=i;j++)
       cin>>matrix[i][j];
     for(int i=row-1;i>=1;i--)
      for(int j=1;j<=i;j++)
      {
       matrix[i][j]+=max(matrix[i+1][j],matrix[i+1][j+1]);
      }
      cout<<matrix[1][1]<<endl;
    }

  • 相关阅读:
    数据访问层之Repository
    IIS执行原理
    异常分析
    Logger
    JSTL
    Kubernetes
    NET Core WordPress
    net平台的rabbitmq
    MySQL can’t specify target table for update in FROM clause
    EqualsBuilder和HashCodeBuilder
  • 原文地址:https://www.cnblogs.com/lzhitian/p/2140076.html
Copyright © 2011-2022 走看看