1050:To the Max
时间限制:
5000ms
内存限制:
65536kB
描述
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sumis referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
输入
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 500. The numbers in the array will be in the range [-127,127].
输出
Output the sum of the maximal sub-rectangle.
样例输入
4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
样例输出
15
#include"iostream"
using namespace std;
int** matrix;
int max_line(int* pass,int n)
{
int temp=pass[0];
int max=0;
for(int i=1;i<n;i++)
{
if(temp>0)
temp+=pass[i];
else
temp=pass[i];//若pass[i]之前线段积和暂存值temp<=0,则舍弃原值,重新赋值为pass[i]
if(temp>max)
max=temp;
}
return max;
}
int max_square(int n)
{
int mmax=0;
for(int i=0;i<n;i++)//起始行
{
int* line=new int[n];//用于存储行数动态变化的rectangular的列向元素累积后的一维数组line
for(int ii=0;ii<n;ii++)//仅当更换起始行的时候才将line初始化为0
line[ii]=0;
for(int j=i;j<n;j++)//从当前行开始扫荡
{
for(int k=0;k<n;k++)//每次扫荡累加一个行
line[k]+=matrix[j][k];
if(max_line(line,n)>mmax)//在起始行确定的情况下,只需考虑终结行是变化的就OK了
mmax=max_line(line,n);
}
}
return mmax;
}
int main()
{
int edge;
cin>>edge;
matrix=new int*[edge];
for(int i=0;i<edge;i++)
matrix[i]=new int[edge];
for(int i=0;i<edge;i++)
for(int j=0;j<edge;j++)
cin>>matrix[i][j];
cout<<max_square(edge)<<endl;
}