zoukankan      html  css  js  c++  java
  • POJ 1961 Period

    Period
    Time Limit: 3000MS   Memory Limit: 30000K
    Total Submissions: 10858   Accepted: 4997

    Description

    For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

    Input

    The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
    number zero on it.

    Output

    For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

    Sample Input

    3
    aaa
    12
    aabaabaabaab
    0

    Sample Output

    Test case #1
    2 2
    3 3
    
    Test case #2
    2 2
    6 2
    9 3
    12 4
    题目大意:输出字符串某一个位置前子串重复的次数,类似于POJ 2406 Power Strings
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    
    int next[1000005];
    char str[1000005];
    
    void getnext()
    {
        int k = -1;
        int j = 0;
        next[0] = -1;
        int nLen = strlen(str);
        while(j < nLen)
        {
            if (k == -1 || str[j] == str[k])
            {
                j++;
                k++;
                next[j] = k;
            }
            else
            {
                k = next[k];
            }
        }
    }
    
    int main()
    {
        int n;
        int ncase = 0;
        while(scanf("%d", &n) != EOF)
        {
            if (n == 0)
            {
                break;
            }
            scanf("%s", str);
            getnext();
            printf("Test case #%d\n", ++ncase);
            int nLen = strlen(str);
            for (int i = 1; i <= nLen; i++)
            {
                if (i % (i - next[i]) == 0 && next[i] != 0)
                {
                    printf("%d %d\n", i, i / (i - next[i]));
                }
            }
            printf("\n");
        }
        return 0;
    }
     
  • 相关阅读:
    flutter 屏幕宽高 状态栏高度
    flutter 图片圆角
    flutter ListView嵌套高度问题
    Dubbo原码解析(version:2.5.3)
    ms
    InnoDB锁问题 & DB事务隔离级别
    Spring父容器与子容器
    Spring bean 的加载过程和生命周期
    logback
    Disconf (version : 2.6.21)
  • 原文地址:https://www.cnblogs.com/lzmfywz/p/3114396.html
Copyright © 2011-2022 走看看