zoukankan      html  css  js  c++  java
  • POJ 1804 Brainman

    Brainman
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 7787   Accepted: 4247

    Description

    Background 
    Raymond Babbitt drives his brother Charlie mad. Recently Raymond counted 246 toothpicks spilled all over the floor in an instant just by glancing at them. And he can even count Poker cards. Charlie would love to be able to do cool things like that, too. He wants to beat his brother in a similar task. 

    Problem 
    Here's what Charlie thinks of. Imagine you get a sequence of N numbers. The goal is to move the numbers around so that at the end the sequence is ordered. The only operation allowed is to swap two adjacent numbers. Let us try an example: 
    Start with: 2 8 0 3 
    swap (2 8) 8 2 0 3 
    swap (2 0) 8 0 2 3 
    swap (2 3) 8 0 3 2 
    swap (8 0) 0 8 3 2 
    swap (8 3) 0 3 8 2 
    swap (8 2) 0 3 2 8 
    swap (3 2) 0 2 3 8 
    swap (3 8) 0 2 8 3 
    swap (8 3) 0 2 3 8

    So the sequence (2 8 0 3) can be sorted with nine swaps of adjacent numbers. However, it is even possible to sort it with three such swaps: 
    Start with: 2 8 0 3 
    swap (8 0) 2 0 8 3 
    swap (2 0) 0 2 8 3 
    swap (8 3) 0 2 3 8

    The question is: What is the minimum number of swaps of adjacent numbers to sort a given sequence?Since Charlie does not have Raymond's mental capabilities, he decides to cheat. Here is where you come into play. He asks you to write a computer program for him that answers the question. Rest assured he will pay a very good prize for it.

    Input

    The first line contains the number of scenarios. 
    For every scenario, you are given a line containing first the length N (1 <= N <= 1000) of the sequence,followed by the N elements of the sequence (each element is an integer in [-1000000, 1000000]). All numbers in this line are separated by single blanks.

    Output

    Start the output for every scenario with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the minimal number of swaps of adjacent numbers that are necessary to sort the given sequence. Terminate the output for the scenario with a blank line.

    Sample Input

    4
    4 2 8 0 3
    10 0 1 2 3 4 5 6 7 8 9
    6 -42 23 6 28 -100 65537
    5 0 0 0 0 0

    Sample Output

    Scenario #1:
    3
    
    Scenario #2:
    0
    
    Scenario #3:
    5
    
    Scenario #4:
    0
    题目大意:归并排序求逆序对。
    #include <stdio.h>
    
    int num[1005];
    int temp[1005];
    int ans = 0;
    
    void Merge(int low, int mid, int high)
    {
        int i = low, j = mid + 1, k = 0;
        while(i <= mid && j <= high)
        {
            if (num[i] <= num[j])
            {
                temp[k] = num[i];
                i++;
                k++;
            }
            else
            {
                ans += mid - i + 1;
                temp[k] = num[j];
                j++;
                k++;
            }
        }
        while(i <= mid)
        {
            temp[k] = num[i];
            i++;
            k++;
        }
        while(j <= high)
        {
            temp[k] = num[j];
            j++;
            k++;
        }
        for (k = 0, i = low; i <= high; k++, i++)
        {
            num[i] = temp[k];
        }
    }
    
    void MergeSort(int lwo, int high)
    {
        if (lwo < high)
        {
            int mid = (lwo + high) / 2;
            MergeSort(lwo, mid);
            MergeSort(mid + 1, high);
            Merge(lwo, mid, high);
        }
    }
    
    int main()
    {
        int nCase, n, nCount = 0;
        scanf("%d", &nCase);
        while(nCase--)
        {
            scanf("%d", &n);
            ans = 0;
            for (int i = 0; i < n; i++)
            {
                scanf("%d", &num[i]);
            }
            MergeSort(0, n - 1);
            printf("Scenario #%d:
    %d
    
    ", ++nCount, ans);
        }
        return 0;
    }
  • 相关阅读:
    后台取得非服务器控件的一种方法(Request.Form.GetKey(i))
    扩展jQuery键盘事件的几个基本方法(练习jQuery插件扩展)
    Javascript得到CheckBoxList的Value
    sql server的count(小技巧)
    oracle数据库约束条件删除、取消、启用
    iis7.0修改网站端口
    session模式和web园
    理解Session State模式+ASP.NET SESSION丢失FAQ (转)
    Gridview中生成的属性rules="all",在Firefox出现内线框解决办法
    一个类windows系统的效果图
  • 原文地址:https://www.cnblogs.com/lzmfywz/p/3255548.html
Copyright © 2011-2022 走看看