zoukankan      html  css  js  c++  java
  • Old Bill

    Old Bill


    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    Among grandfather��s papers a bill was found:

    72 turkeys $_679_

    The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are now illegible. What are the two faded digits and what was the price of one turkey?

    We want to write a program that solves a general version of the above problem:

    N turkeys $_XYZ_

    The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkey is an integer number of dollars, and that all the turkeys cost the same price.

    Given N, X, Y , and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two faded digits and the maximum price per turkey for the turkeys.

    Input

    The input consists of T test cases. The number of test cases (T) is given on the first line of the input file. The first line of each test case contains an integer N (0 < N < 100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y , and Z, separated by a space, of the original price $_XYZ_.

    Output

    For each test case, your program has to do the following. For a test case, there may be more than one candidate for the original price or there is none. In the latter case your program is to report 0. Otherwise, if there is more than one candidate for the original price, the program is to report the two faded digits and the maximum price per turkey for the turkeys. The following shows sample input and output for three test cases.

    Sample Input

    3
    72
    6 7 9
    5
    2 3 7
    78
    0 0 5

    Sample Output

    3 2 511
    9 5 18475
    0

    很简单的一道题目,开始的时候是我想多了,原来最简单的两重循环就可以满足效率要求了。原先我还想着是不是要根据N的值先确定总价格的尾数,然后再进行循环呢,原来不用这么麻烦啊。

    #include<iostream>
    
    using namespace std;
    
    int main()
    
    {
    
      int cases;cin>>cases;
    
      while(cases--)
    
      {
    
        int n,x,y,z;
    
        cin>>n>>x>>y>>z;
    
        bool breakFor = false;
    
        for(int thousand = 9; thousand >= 1; thousand--)
    
        {
    
          breakFor = false;
    
          for(int unit = 9; unit >= 0; unit--)
    
          {
    
            int destination = thousand*10000 + x*1000 + y*100 + z*10 + unit;
    
            if(destination % n == 0)
    
            {
    
              cout<<thousand<<""<<unit<<""<<destination/n<<endl;
    
              breakFor = true;
    
              break;
    
            }
    
          }
    
          if(breakFor)
    
            break;
    
        }
    
        if(!breakFor)
    
          cout<<0<<endl;
    
      }
    
    }
  • 相关阅读:
    北京礼品在线盛大发布
    医生专用手机(智能、导航、名片扫描、医生掌上电子助手)
    医生专用手机/PDA
    DEDE 栏目内容 {dede:field.content/} 输入值不保存解决方法
    礼至上礼品策划中心
    ASP.NET WAP开发
    国内唯一具有智能礼品推荐系统
    招聘发帖兼职人员帖酬高达0.5元/条http://li010.com
    软件文档知多少?
    地高人柳州地区高中校友大联盟 地高校友录,聚会活动,今日地高,母校追忆,校友今朝,职场生涯
  • 原文地址:https://www.cnblogs.com/malloc/p/2392326.html
Copyright © 2011-2022 走看看