zoukankan      html  css  js  c++  java
  • IBM Minus One

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

    After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

    Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

    Input

    The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

    Output

    For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

    Print a blank line after each test case.

    Sample Input

    2
    HAL
    SWERC

    Sample Output

    String #1
    IBM

    String #2
    TXFSD


    Source: Southwestern Europe 1997, Practice

    标准水题。。。。

    #include<iostream>
    
    #include<string>
    
    using namespace std;
    
    int main()
    
    {
    
      int times;
    
      while(cin>>times)
    
      {
    
        string s;
    
        for(int i = 0;i < times; i++)
    
        {
    
          cin>>s;
    
          cout<<"String #"<<i + 1<<endl;
    
          for(int j = 0; j < s.length(); j++)
    
          {
    
            if(s[j] == 'Z')
    
              cout<<'A';
    
            else
    
              cout<<char(s[j] + 1);
    
          }
    
          cout<<endl<<endl;
    
        }
    
      }
    
    }
  • 相关阅读:
    金刚经与心经之比较
    ECMWF 和 GFS 模型
    LSTM之父Jürgen Schmidhuber评图灵
    STM32相关知识点
    最全C++11/14/17/20/23 的新特性代码案例
    C++ 在线工具
    如何在 Proteus 中设计 PCB
    STM32电源框图解析
    【新特性速递】填一个坑
    【新特性速递】表格加载速度足足 3 倍提升,爱了爱了
  • 原文地址:https://www.cnblogs.com/malloc/p/2392542.html
Copyright © 2011-2022 走看看