zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1241 Geometry Made Simple

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c. This is called Pythagora's Law.

    Here we consider the problem of computing the length of the third side, if two are given.

    Input

    The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal to -1 (the 'unknown' side), the others are positive (the 'given' sides).

    A description having a=b=c=0 terminates the input.

    Output

    For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the 'given' side lengths. Otherwise output the length of the 'unknown' side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

    Print a blank line after each test case.

    Sample Input

    3 4 -1
    -1 2 7
    5 -1 3
    0 0 0


    Sample Output

    Triangle #1
    c = 5.000
    Triangle #2
    a = 6.708
    Triangle #3
    Impossible.


    Source: Southwestern Europe 1997, Practice
    #include<iostream>
    
    #include<math.h>
    
    #include<iomanip>
    
    using namespace std;
    
    int main()
    
    {
    
      double a, b, c;
    
      int i = 1;
    
      while(cin>>a>>b>>c && (a || b || c))
    
      {
    
        cout<<"Triangle #"<<i<<endl;
    
        if(c != -1)
    
        {
    
          if ( a >= c || b >= c)
    
            cout<<"Impossible."<<endl;
    
          else
    
          {
    
            if(a == -1)
    
              cout<<"a = "<<fixed<<setprecision(3)<<sqrt(c*c - b*b)<<endl;
    
            if(b == -1)
    
              cout<<"b = "<<fixed<<setprecision(3)<<sqrt(c*c - a*a)<<endl;
    
          }
    
        }
    
        else
    
        {
    
          cout<<"c = "<<fixed<<setprecision(3)<<sqrt(a*a + b*b)<<endl;
    
        }
    
        cout<<endl;
    
        i++;
    
      }
    
    }
  • 相关阅读:
    俩人搞对象,山上骑马
    历史不会偏袒任何一个缺乏正义、良知的人。
    力量和对力量的控制
    超级管理员
    电信F412
    prim算法
    Maven pom.xml配置详解
    PorterDuffXfermode的用法
    使用MaskFilter
    Android drawText获取text宽度的三种方式
  • 原文地址:https://www.cnblogs.com/malloc/p/2419465.html
Copyright © 2011-2022 走看看