zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1295 Reverse Text

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.


    Input Specification

    The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.

    Output Specification

    For each test case, print a line containing the characters of the input line in reverse order.

    Sample Input

    3
    Frankly, I don't think we'll make much
    money out of this scheme.
    madam I'm adam

    Sample Output
    hcum ekam ll'ew kniht t'nod I ,ylknarF
    .emehcs siht fo tuo yenom
    mada m'I madam


    Source: Southwestern Europe 1996, Practice

    #include<iostream>
    
    #include<string>
    
    #include<algorithm>
    
    using namespace std;
    
    
    
    int main()
    
    {
    
      int cases;cin>>cases;
    
      string s;
    
      getline(cin, s);
    
      while(cases-- && getline(cin, s))
    
      {
    
        reverse(s.begin(), s.end());
    
        cout<<s<<endl;
    
      }
    
      return 0;
    
    }
  • 相关阅读:
    Single Threaded Execution
    多线程(第三天)
    多线程(第二天)
    IE中float:right单独一行
    web.xml配置
    java调用asmx的webservice
    跨域访问
    jsp页面导入jstl标签
    搜索dwr做即时聊天的时候看到的问题
    LigerUI tree在ie下显示不出来/LigerUI 控件在ie下错乱
  • 原文地址:https://www.cnblogs.com/malloc/p/2419473.html
Copyright © 2011-2022 走看看