zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1295 Reverse Text

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.


    Input Specification

    The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.

    Output Specification

    For each test case, print a line containing the characters of the input line in reverse order.

    Sample Input

    3
    Frankly, I don't think we'll make much
    money out of this scheme.
    madam I'm adam

    Sample Output
    hcum ekam ll'ew kniht t'nod I ,ylknarF
    .emehcs siht fo tuo yenom
    mada m'I madam


    Source: Southwestern Europe 1996, Practice

    #include<iostream>
    
    #include<string>
    
    #include<algorithm>
    
    using namespace std;
    
    
    
    int main()
    
    {
    
      int cases;cin>>cases;
    
      string s;
    
      getline(cin, s);
    
      while(cases-- && getline(cin, s))
    
      {
    
        reverse(s.begin(), s.end());
    
        cout<<s<<endl;
    
      }
    
      return 0;
    
    }
  • 相关阅读:
    outline basic
    Best lua IDE
    Powershell core
    [转]ceph pg peering过程分析
    [转]ceph rbd到OSD的数据映射
    [转]ceph三种存储接口--块设备-文件系统-对象存储
    ceph monitor----paxos算法1
    ceph monitor----初始化和选举
    ceph monitor---总结1
    [转]ceph RADOS----概述
  • 原文地址:https://www.cnblogs.com/malloc/p/2419473.html
Copyright © 2011-2022 走看看