zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1292 Integer Inquiry

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

    The final input line will contain a single zero on a line by itself.

    Output
    Your program should output the sum of the VeryLongIntegers given in the input.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.


    Sample Input

    1

    123456789012345678901234567890
    123456789012345678901234567890
    123456789012345678901234567890
    0


    Sample Output

    370370367037037036703703703670


    Source: East Central North America 1996

    #include<iostream>
    
    #include<string>
    
    #include<algorithm>
    
    using namespace std;
    
    string MAdd(string& a, string& b)
    
    {
    
      reverse(a.begin(), a.end());
    
      reverse(b.begin(), b.end());
    
      int carry = 0;
    
      int a0, b0, c0;
    
      int i = 0;
    
      for(; i < a.length();i++)
    
      {
    
        if( i >= b.length())
    
          b0 = 0;
    
        else
    
        {
    
          b0 = b[i] - '0';
    
        }
    
        a0 = a[i] - '0';
    
        c0 = a0 + b0 + carry;
    
        if(c0 >= 10)
    
        {
    
          a[i] = c0 - 10 + '0';
    
          carry = 1;
    
        }
    
        else
    
        {
    
          a[i] = c0 + '0';
    
          carry = 0;
    
        }
    
      }
    
      if(carry == 1)
    
      {
    
        reverse(a.begin(), a.end());
    
        return "1" + a;
    
      }
    
      else
    
      {
    
        reverse(a.begin(), a.end());
    
        return a;    
    
      }
    
    }
    
    int main()
    
    {
    
      int blocks;cin>>blocks;
    
      for(int block = 0; block < blocks; block++)
    
      {
    
        string state;
    
        if(block == 0)//仅在第一次的时候有如下两个空行
    
        {
    
          getline(cin,state);//用getline 吃掉输入blocks之后的回车
    
          getline(cin,state);//题目要求的空行
    
        }
    
        
    
        string num, result = "-1";
    
        int cases = 1;
    
        while(cin>>num && (num != "0"))
    
        {
    
          if(result == "-1")
    
            result = num;
    
          else
    
          {
    
            result = (result.length() > num.length() ? MAdd(result, num): MAdd(num, result));
    
          }
    
        }
    
        cout<<result<<endl;
    
        if(block != blocks - 1)//最后一次输出没有空行
    
        {
    
          cout<<endl;
    
        }
    
      }
    
    }
  • 相关阅读:
    mongodump
    spring发邮件被识别为垃圾邮件:org.springframework.mail.MailSendException: Failed messages: com.sun.mail.smtp.SMTPSendFailedException: 554 DT:SPM 163
    springboot拦截器注入bean失败实例
    springboot拦截器配置、消息头校验、重复请求过滤
    web接口服务端鉴权
    spring data jpa指定联合索引
    spring data jpa自定义更新实现实例
    win10根据端口查进程以及杀进程
    linux修改jar包中的springboot配置文件
    linux修改配置文件解决mysql中文乱码和指定数据库存储引擎
  • 原文地址:https://www.cnblogs.com/malloc/p/2419803.html
Copyright © 2011-2022 走看看