zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1514 Fake Tickets

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    Your school organized a big party to celebrate your team brilliant win in the prestigious, worldfamous ICPC (International Collegiate Poetry Contest). Everyone in your school was invited for an evening which included cocktail, dinner and a session where your team work was read to the audience. The evening was a success - many more people than you expected showed interested in your poetry - although some critics of yours said it was food rather than words that attracted such an audience.
    Whatever the reason, the next day you found out why the school hall had seemed so full: the school director confided he had discovered that several of the tickets used by the guests were fake. The real tickets were numbered sequentially from 1 to N (N <= 10000). The director suspects some people had used the school scanner and printer from the Computer Room to produce copies of the real tickets. The director gave you a pack with all tickets collected from the guests at the party's entrance, and asked you to determine how many tickets in the pack had 'clones', that is, another ticket with the same sequence number.

    Input
    The input contains data for several test cases. Each test case has two lines. The first line contains two integers N and M which indicate respectively the number of original tickets and the number of persons attending the party (1 <= N <= 10000 and 1 <= M <= 20000). The second line of a test case contains M integers Ti representing the ticket numbers in the pack the director gave you (1 <= Ti <= N). The end of input is indicated by N = M = 0.

    Output
    For each test case your program should print one line, containing the number of tickets in the pack that had another ticket with the same sequence number.

    Sample Input

    5 5
    3 3 1 2 4
    6 10
    6 1 3 6 6 4 2 3 1 2
    0 0

    Sample Output

    1
    4


    Source: South America 2002, Practice

    题目要计算的是有多少票被复制了,而不是假票的数量!

    #include<iostream>
    
    #include<set>
    
    using namespace std;
    
    int main()
    
    {
    
      int n,m;
    
      while(cin>>n>>m && (n || m))
    
      {
    
        int tickets;
    
        set<int> s,s0;
    
        while(m-- && cin>>tickets)
    
        {
    
          if(s.find(tickets) != s.end())
    
            s0.insert(tickets);
    
          else
    
            s.insert(tickets);
    
        }
    
        cout<<s0.size()<<endl;
    
      }
    
      return 0;
    
    }
  • 相关阅读:
    一道小学数学题
    Ubuntu下使用git提交代码至GitHub
    C#几个小知识点
    C#中巧用#if DEBUG 进行调试
    使用 HPC Pack 为 Azure 中的 Windows HPC 工作负荷创建和管理群集的选项
    使用 Chef 自动执行 Azure 虚拟机部署
    在 Azure 中管理 Windows 虚拟机的可用性
    什么是 Azure 中的虚拟机规模集?
    从 Azure 下载 Windows VHD
    如何使用 Packer 在 Azure 中创建 Windows 虚拟机映像
  • 原文地址:https://www.cnblogs.com/malloc/p/2427384.html
Copyright © 2011-2022 走看看