zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1402 Magnificent Meatballs

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    Sam and Ella run a catering service. They like to put on a show when serving meatballs to guests seated at round tables. They march out of the kitchen with pots of meatballs and start serving adjacent guests. Ella goes counterclockwise and Sam goes clockwise, until they both plop down their last meatball, at the same time, again at adjacent guests. This impressive routine can only be accomplished if they can divide the table into two sections, each having the same number of meatballs. You are to write a program to assist them.

    At these catering events, each table seats 2 <= N <= 30 guests. Each guest orders at least one and at most nine meatballs. Each place at the table is numbered from 1 to N, with the host at position 1 and the host's spouse at position N. Sam always serves the host first then proceeds to serve guests in increasing order. Ella serves the spouse first, then serves guests in decreasing order. The figures illustrate the first two example input cases.

    Input consists of one or more test cases. Each test case contains the number of guests N followed by meatballs ordered by each guest, from guest 1 to guest N. The end of the input is a line with a single zero.

    For each table, output a single line with the ending positions for Sam and Ella, or the sentence indicating an equal partitioning isn't possible. Use the exact formatting shown below.

    Sample Input
    5 9 4 2 8 3
    5 3 9 4 2 8
    6 1 2 1 2 1 2
    6 1 2 1 2 1 1
    0

    Sample Output
    Sam stops at position 2 and Ella stops at position 3.
    No equal partitioning.
    No equal partitioning.
    Sam stops at position 3 and Ella stops at position 4.


    Source: Mid-Central USA 2002
    #include<iostream>
    
    using namespace std;
    
    int main()
    
    {
    
      int guests;
    
      while(cin>>guests && guests)
    
      {
    
        int *meatBallList = new int[guests];
    
        int totalMeatBall = 0;
    
        for(int i = 0; i < guests;i++)
    
        {
    
          cin>>*(meatBallList + i);
    
          totalMeatBall += *(meatBallList + i);
    
        }
    
        if(totalMeatBall%2 != 0)
    
        {
    
          cout<<"No equal partitioning."<<endl;
    
        }
    
        else
    
        {
    
          int sam = 0, equalPartition = totalMeatBall/2;
    
          for(int j = 0; j < guests; j++)
    
          {
    
            sam += *(meatBallList + j);
    
            if(sam == equalPartition)
    
            {
    
              cout<<"Sam stops at position "<<j + 1<<" and Ella stops at position "<<j + 2<<"."<<endl;
    
              break;
    
            }
    
            else if( sam > equalPartition)
    
            {
    
              cout<<"No equal partitioning."<<endl;
    
              break;
    
            }
    
          }
    
        }
    
      }
    
      return 0;
    
    }
  • 相关阅读:
    linux下硬盘分区、格式化以及文件管理系统
    linux下的文档处理及tar命令
    linux文件及目录的权限管理
    linux用户和群组
    linux下mysql的安装与使用
    linux上uwsgi+nginx+django发布项目
    linux虚拟环境搭建
    linux目录文件操作
    linux基本命令
    rbac组件之权限初始化(五)
  • 原文地址:https://www.cnblogs.com/malloc/p/2428558.html
Copyright © 2011-2022 走看看