zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1763 A Simple Question of Chemistry

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    Your chemistry lab instructor is a very enthusiastic graduate student who clearly has forgotten what their undergraduate Chemistry 101 lab experience was like. Your instructor has come up with the brilliant idea that you will monitor the temperature of your mixture every minute for the entire lab. You will then plot the rate of change for the entire duration of the lab.

    Being a promising computer scientist, you know you can automate part of this procedure, so you are writing a program you can run on your laptop during chemistry labs. (Laptops are only occasionally dissolved by the chemicals used in such labs.) You will write a program that will let you enter in each temperature as you observe it. The program will then calculate the difference between this temperature and the previous one, and print out the difference. Then you can feed this input into a simple graphing program and finish your plot before you leave the chemistry lab.


    Input

    The input is a series of temperatures, one per line, ranging from -10 to 200. The temperatures may be specified up to two decimal places. After the final observation, the number 999 will indicate the end of the input data stream. All data sets will have at least two temperature observations.

    Output

    Your program should output a series of differences between each temperature and the previous temperature. There is one fewer difference observed than the number of temperature observations (output nothing for the first temperature). Differences are always output to two decimal points, with no leading zeroes (except for the ones place for a number less than 1, such as 0.01) or spaces.

    After the final output, print a line with "End of Output"

    Sample Input

    10.0
    12.05
    30.25
    20
    999

    Sample Output

    2.05
    18.20
    -10.25
    End of Output


    Source: Mid-Atlantic USA 2003

    #include<iostream>
    
    #include<iomanip>
    
    using namespace std;
    
    int main()
    
    {
    
      double pre = 1000, crt;
    
      while(cin>>crt && crt != 999)
    
      {
    
        if(pre < 1000)
    
          cout<<fixed<<setprecision(2)<<crt - pre<<endl;
    
        pre = crt;
    
      }
    
      cout<<"End of Output"<<endl;
    
      return 0;
    
    }
  • 相关阅读:
    第五章 kubernetes常见故障排错
    第二十五章 Centos7下二进制安装Mysql-5.7.34
    第二十四章 MySQL导入数据常见报错解决
    第二十三章 Centos7 下 Mysql 8.0.24编译安装
    第二十二章 Centos7下 Mysql 8.0.24 二进制安装
    第二十一章 MySQL数据库优化
    Sqoop导入数据到mysql数据库报错:ERROR tool.ExportTool: Error during export: Export job failed!
    python读取csv、excel、mysql内容
    WTF表单验证
    Flask_WTF实现表单
  • 原文地址:https://www.cnblogs.com/malloc/p/2482843.html
Copyright © 2011-2022 走看看