zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1858 Soundex

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding.
    Soundex coding involves translating each word into a series of digits in which each digit represents a letter:

    1 represents B, F, P, or V
    2 represents C, G, J, K, Q, S, X, or Z
    3 represents D or T
    4 represents L
    5 represents M or N
    6 represents R

    The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with the same Soundex coding are considered equivalent.

    Input
    Each line of input contains a single word, all upper case, less than 20 letters long.

    Output

    For each line of input, produce a line of output giving the Soundex code.

    Sample Input
    KHAWN
    PFISTER
    BOBBY

    Sample Output
    25
    1236
    11


    Source: University of Waterloo Local Contest 1999.09.25

    #include<iostream>
    
    #include<string>
    
    using namespace std;
    
    int main(void)
    
    {
    
      string uword;
    
      while(cin>>uword)
    
      {
    
        int preI = 0, crtI = 0;
    
        for(int i = 0; i < uword.length(); i++)
    
        {
    
          switch(uword[i])
    
          {
    
          case 'B':case 'F':case 'P':case 'V':
    
            crtI = 1;
    
            if(preI != crtI)
    
            {
    
              cout<<crtI;
    
              preI = crtI;
    
            }
    
            break;
    
          case 'C':case 'G':case 'J':case 'K':case 'Q':case 'S':case 'X':case 'Z':
    
            crtI = 2;
    
            if(preI != crtI)
    
            {
    
              cout<<crtI;
    
              preI = crtI;
    
            }
    
            break;
    
          case 'D':case 'T':
    
            crtI = 3;
    
            if(preI != crtI)
    
            {
    
              cout<<crtI;
    
              preI = crtI;
    
            }
    
            break;
    
          case 'L':
    
            crtI = 4;
    
            if(preI != crtI)
    
            {
    
              cout<<crtI;
    
              preI = crtI;
    
            }
    
            break;
    
          case 'M':case 'N':
    
            crtI = 5;
    
            if(preI != crtI)
    
            {
    
              cout<<crtI;
    
              preI = crtI;
    
            }
    
            break;
    
          case 'R':
    
            crtI = 6;
    
            if(preI != crtI)
    
            {
    
              cout<<crtI;
    
              preI = crtI;
    
            }
    
            break;
    
          default:
    
            preI = 0;
    
            break;
    
          }
    
        }
    
        cout<<endl;
    
      }
    
      return 0;
    
    }
  • 相关阅读:
    Android.02.Button
    Android.01. TextView
    Android.00.IDEA中Android开发环境搭建
    Java34.Marven
    CSS 滚动条样式
    不常用的HTML和CSS 记录
    JS 规则
    svg转化成canvas以便生成base64位的图片
    ArcGIS Server 10.1 安装教程
    ArcGis API JS 4.X 本地化部署
  • 原文地址:https://www.cnblogs.com/malloc/p/2487731.html
Copyright © 2011-2022 走看看