zoukankan      html  css  js  c++  java
  • 1009 Product of Polynomials(25 分)

    1009 Product of Polynomials(25 分)

    This time, you are supposed to find A×B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

    N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

    where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1K10, 0NK​​<<N2​​<N1​​1000.

    Output Specification:

    For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

    Sample Input:

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    

    Sample Output:

    3 3 3.6 2 6.0 1 1.6


    //关键点:多项式乘积之后的范围为0~2000,所以设置double p[2001] = {0};
    
    #include<stdio.h>
    #include<iostream>
    #include<iomanip>
    
    using namespace std;
    
    int main()
    {
        int k1;
        cin >> k1;
        int a[1001] = {0};//存放多项式A的指数
        double b[1001] = {0};//存放多项式A的系数
        for(int i = 0;i< k1;i++)
        {
            cin >> a[i];
            cin >> b[i];
        }
    
        int k2;
        cin >> k2;
        double p[2001] = {0};//存放乘积的指数对应的系数
        for(int i = 0;i < k2;i++)
        {
            int ex;
            double co;//多项式B的指数,系数
            cin >> ex;
            cin >> co;
    
            for(int j = 0;j < k1;j++)
            {
                p[ex + a[j]] += co*b[j];
            }
        }
    
        int count = 0;//结果的项数
        for(int i = 2000;i >= 0;i--)
        {
            if(p[i] != 0)
            {
                count++;
            }
        }
        cout << count;
        for(int i = 2000;i >= 0;i--)
        {
            if(p[i] != 0)
            {
                cout << " " << i << " " << setiosflags(ios::fixed) << setprecision(1) << p[i];
            }
        }
        cout <<endl;
    
        return 0;
    }
  • 相关阅读:
    dfs模板
    24点
    个人阅读三
    个人阅读作业2:关于项目经历的心得
    代码复审
    Pair Project1:电梯控制程序
    第二次个人项目——阅读经典教材
    THE First Individual Project
    个人阅读作业3
    个人阅读作业2
  • 原文地址:https://www.cnblogs.com/meiqin970126/p/9600885.html
Copyright © 2011-2022 走看看