zoukankan      html  css  js  c++  java
  • 杭电1162Eddy's picture

    Eddy's picture

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 28   Accepted Submission(s) : 17

    Font: Times New Roman | Verdana | Georgia

    Font Size:

    Problem Description

    Eddy begins to like  painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room,  and he usually  puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting  pictures ,so Eddy creates a problem for the his friends of you.
    Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally  to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

    Input

    The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

    Input contains multiple test cases. Process to the end of file.

    Output

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

    Sample Input

    3
    1.0 1.0
    2.0 2.0
    2.0 4.0
    

    Sample Output

    3.41
    

    这道题也是非常easy的最短路径问题

    代码:

    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    #define INF 1 << 30
    double a[101] , b[101] , map[101][101] ;
    double dis[101] ;
    int used[101] ;
    void prim(int n)
    {
     int c = 0 ;
     int i = 0 , j = 0 ;
     double sum = 0 ;
     dis[1] = 0 ;
     for(i = 1 ; i <= n ; i++)
     {
      double min = INF ;
      c = 0 ;
      for(j = 1 ; j <= n ; j++)
      {
             if(!used[j] && dis[j] < min)
       {
        min = dis[j] ;
        c =j ;
       }
      }
      used[c] = 1 ;
      for(j  = 1 ; j <= n ; j++ )
      {
       if(!used[j] && dis[j] > map[c][j])
        dis[j] = map[c][j] ;
      }
     }
     
     for(i = 1 ; i <= n ; i++)
      sum += dis[i] ;
     printf("%.2lf ",sum);
    }
    int main()
    {
     int n = 0 ;
     while(~scanf("%d",&n))
     {
      memset(a , 0 , sizeof( a ) ) ;
      memset(b , 0 , sizeof( b ) ) ;
      int i = 0 , j = 0 ;
      for(i = 1 ; i <= n ; i++)
      {
       for(j = 1 ; j <= n ; j++)
           map[i][j] = INF ;
       dis[i] = INF ;
       used[i] = 0 ;
      }
      for(i = 1 ; i <= n ; i++)
      {
                scanf("%lf%lf" , &a[i] , &b[i] );
      }
      double m = 0 , x = 0;
      for(i = 1 ; i <= n ; i++ )
      {
                for(j = 1 ; j <= n ; j++)
       {
        x = (a[j]-a[i])*(a[j]-a[i])+(b[j]-b[i])*(b[j]-b[i]) ;
        m = sqrt( x ) ;
        map[i][j] = map[j][i] = m ;
       }
      }
      prim( n );
     }
     return 0 ;
    }

  • 相关阅读:
    基于springboot1.5.9整合shiro时出现静态文件找不到的问题
    基于springboot多模块项目使用maven命令打成war包放到服务器上运行的问题
    关于使用map存放数据乱序”问题“
    springboot1.5.9整合websocket实现实时显示的小demo
    SpringBoot1.5.10.RELEASE配置mybatis的逆向工程
    SpringBoot1.5.10.RELEASE整合druid时,在druid monitor界面出现(*) property for user to setup
    SpringBoot1.5.10.RELEASE整合druid
    SpringBoot1.5.10.RELEASE项目如何在tomcat容器中运行
    JS学习-01
    List,Set,Map在java.util包下都是接口 List有两个实现类:ArrayList和LinkedList Set有两个实现类:HashSet和LinkedHashSet AbstractSet实现了Set
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/4223464.html
Copyright © 2011-2022 走看看