zoukankan      html  css  js  c++  java
  • HDU1325 Is It A Tree? 【并查集】

    Is It A Tree?

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 14197    Accepted Submission(s): 3170


    Problem Description
    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
    There is exactly one node, called the root, to which no directed edges point.

    Every node except the root has exactly one edge pointing to it.

    There is a unique sequence of directed edges from the root to each node.

    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

     

    Input
    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
     

    Output
    For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
     

    Sample Input
    6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
     

    Sample Output
    Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
    题意:给定一个图,推断是否为树。

    题解:须要推断森林,推断回路,推断入度是否大于1.

    #include <stdio.h>
    #include <string.h>
    #define maxn 10002
    
    int in[maxn], pre[maxn], count;
    bool vis[maxn];
    
    int ufind(int k)
    {
    	int a = k;
    	while(pre[k] != -1) k = pre[k];
    	int b;
    	while(pre[a] != -1){
    		b = pre[a];
    		pre[a] = k;
    		a = b;
    	}
    	return k;
    }
    
    int main()
    {
    	//freopen("stdin.txt", "r", stdin);
    	int a, b, ok = 1, cas = 1;
    	memset(pre, -1, sizeof(pre));
    	while(scanf("%d%d", &a, &b)){
    		if(a < 0) break;
    		if(a == 0){
    			printf("Case %d is ", cas++);
    			if(count != 1) ok = 0;
    			printf(ok ? "a tree.
    " : "not a tree.
    ");
    			ok = 1; count = 0;
    			memset(in, 0, sizeof(in));
    			memset(vis, 0, sizeof(vis));
    			memset(pre, -1, sizeof(pre));
    			continue;
    		}
    		if(!ok) continue;
    		if(!vis[a]){ ++count; vis[a] = 1; }
    		if(!vis[b]){ ++count; vis[b] = 1; }
    		if(++in[b] > 1) ok = 0;
    		a = ufind(a); b = ufind(b);
    		if(a == b) ok = 0;
    		else { pre[a] = b; --count; }
    	}
    	return 0;
    }


  • 相关阅读:
    bzoj1096: [ZJOI2007]仓库建设
    bzoj3289: Mato的文件管理
    bzoj1878: [SDOI2009]HH的项链
    bzoj1295: [SCOI2009]最长距离
    bzoj1056: [HAOI2008]排名系统 && 1862: [Zjoi2006]GameZ游戏排名系统
    vijosP1026毒药?解药?
    bzoj1293: [SCOI2009]生日礼物
    bzoj1483: [HNOI2009]梦幻布丁
    PCB开窗
    3W原则
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/4264046.html
Copyright © 2011-2022 走看看