zoukankan      html  css  js  c++  java
  • hdu 1698

    Just a Hook

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 16563    Accepted Submission(s): 8234


    Problem Description
    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



    Now Pudge wants to do some operations on the hook.

    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
    The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

    For each cupreous stick, the value is 1.
    For each silver stick, the value is 2.
    For each golden stick, the value is 3.

    Pudge wants to know the total value of the hook after performing the operations.
    You may consider the original hook is made up of cupreous sticks.
     

    Input
    The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
    For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
    Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
     

    Output
    For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
     

    Sample Input
    1 10 2 1 5 2 5 9 3
     

    Sample Output
    Case 1: The total value of the hook is 24.
     

    Source
     

    AC代码:
    #include<iostream>
    using namespace std;
    struct Node{
        int left,right;
        int s;
    }a[400010];
    void built(int cur,int x,int y){
        a[cur].left=x;
        a[cur].right=y;
        a[cur].s=1;
        if(x<y){
            int mid=(x+y)>>1;
            built(cur<<1,x,mid);
            built(cur<<1 | 1,mid+1,y);
        }
    }
    void insert(int val,int cur,int x,int y){
        if(a[cur].left==x && a[cur].right==y){
            a[cur].s=val;
            return ;
        }
        if(a[cur].left==a[cur].right){
            a[cur].s=val;
            return ;
        }
        if(a[cur].s){
            a[cur<<1].s=a[cur<<1 | 1].s=a[cur].s;
            a[cur].s=0;
        }
        int mid=(a[cur].right+a[cur].left)>>1;
        if(y<=mid)
            insert(val,cur<<1,x,y);
        else if(x>mid)
            insert(val,cur<<1 |1,x,y);
        else{
            insert(val,cur<<1,x,mid);
            insert(val,cur<<1 | 1,mid+1,y);
        }
    }
    int sum(int cur,int x,int y){
        if(a[cur].s){
            //cout<<a[cur].s<<' '<<a[cur].left<<' '<<a[cur].right<<endl;
            return (1+a[cur].right-a[cur].left)*a[cur].s;
        }
        int mid=(x+y)>>1;
        return sum(cur<<1,x,mid)+sum(cur<<1 |1,mid+1,y);
    }
    int main(){
        int T; cin>>T;
        for(int j=1;j<=T;j++){
            int n; cin>>n;
            built(1,1,n);
            int t; cin>>t;
            for(int i=0;i<t;i++){
                int x,y,val;
                cin>>x>>y>>val;
                insert(val,1,x,y);
            }
            cout<<"Case "<<j<<": The total value of the hook is "<<sum(1,1,n)<<'.'<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    课表
    hz评测机的迷惑操作
    联赛模拟测试16
    第四阶段总结
    震惊!OI居然还考天体运动
    简单题 题解
    P2340 [USACO03FALL]Cow Exhibition G题解
    题目分享I 三代目
    题目分享H 三代目
    题目分享G 三代目
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/4565959.html
Copyright © 2011-2022 走看看