zoukankan      html  css  js  c++  java
  • HDU 4085 Steiner树模板称号

    Dig The Wells

    Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 971    Accepted Submission(s): 416


    Problem Description
    You may all know the famous story “Three monks”. Recently they find some places around their temples can been used to dig some wells. It will help them save a lot of time. But to dig the well or build the road to transport the water will cost money. They do not want to cost too much money. Now they want you to find a cheapest plan.
     

    Input
    There are several test cases.
    Each test case will starts with three numbers n , m, and p in one line, n stands for the number of monks and m stands for the number of places that can been used, p stands for the number of roads between these places. The places the monks stay is signed from 1 to n then the other m places are signed as n + 1 to n + m. (1 <= n <= 5, 0 <= m <= 1000, 0 <=p <= 5000)
    Then n + m numbers followed which stands for the value of digging a well in the ith place.
    Then p lines followed. Each line will contains three numbers a, b, and c. means build a road between a and b will cost c.
     

    Output
    For each case, output the minimum result you can get in one line.
     

    Sample Input
    3 1 3 1 2 3 4 1 4 2 2 4 2 3 4 4 4 1 4 5 5 5 5 1 1 5 1 2 5 1 3 5 1 4 5 1
     

    Sample Output
    6 5


    题意:有n个和尚。每个和尚一个庙,有m个村庄,p条路。每条路有费用,每个地方打井也须要费用,求最少花多少钱能够使得全部和尚喝上水。

    斯坦纳树比較裸的问题。

    代码:

    /* ***********************************************
    Author :rabbit
    Created Time :2014/7/17 0:59:57
    File Name :13.cpp
    ************************************************ */
    #pragma comment(linker, "/STACK:102400000,102400000")
    #include <stdio.h>
    #include <iostream>
    #include <algorithm>
    #include <sstream>
    #include <stdlib.h>
    #include <string.h>
    #include <limits.h>
    #include <string>
    #include <time.h>
    #include <math.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <map>
    using namespace std;
    #define INF 100000000
    #define eps 1e-8
    #define pi acosi
    typedef long long ll;
    int head[1100],tol;
    struct Edge{
    	int next,to,val;
    }edge[1001000];
    void addedge(int u,int v,int w){
    	edge[tol].to=v;
    	edge[tol].next=head[u];
    	edge[tol].val=w;
    	head[u]=tol++;
    }
    int weight[1100],d[1100][1<<5],dp[1100],in[1010][1<<5];
    int main()
    {
         //freopen("data.in","r",stdin);
         //freopen("data.out","w",stdout);
         int n,m,p;
    	 while(~scanf("%d%d%d",&n,&m,&p)){
    		 memset(head,-1,sizeof(head));tol=0;
    		 for(int i=0;i<n+m;i++)
    			 scanf("%d",&weight[i]);
    		 while(p--){
    			 int u,v,w;
    			 scanf("%d%d%d",&u,&v,&w);
    			 u--;v--;
    			 addedge(u,v,w);
    			 addedge(v,u,w);
    		 }
    		 for(int i=0;i<n+m;i++)
    			 for(int j=0;j<(1<<n);j++)
    				 d[i][j]=INF;
    		 for(int i=0;i<(1<<n);i++)dp[i]=INF;
    		 memset(in,0,sizeof(in));
    		 for(int i=0;i<n;i++)
    			 d[i][1<<i]=weight[i];
    		 for(int i=1;i<(1<<n);i++){
    			 queue<int> Q;
    			 for(int j=0;j<n+m;j++){
    				 for(int k=i&(i-1);k;k=(k-1)&i)
    					 d[j][i]=min(d[j][i],d[j][i-k]+d[j][k]-weight[j]);
    				 if(d[j][i]<INF)Q.push(100000*j+i),in[j][i]=1;
    			 }
    			 while(!Q.empty()){
    				 int v=Q.front()/100000,t=Q.front()%100000;
    				 Q.pop();
    				 in[v][t]=0;
    				 for(int e=head[v];e!=-1;e=edge[e].next){
    					 int s=edge[e].to;
    					 if(d[s][t]>d[v][t]+edge[e].val+weight[s]-weight[v]){
    						 d[s][t]=d[v][t]+edge[e].val+weight[s]-weight[v];
    						 if(!in[s][t]){
    							 in[s][t]=1;
    							 Q.push(100000*s+t);
    						 }
    					 }
    				 }
    			 }
    		 }
    		 for(int i=1;i<(1<<n);i++)
    			 for(int j=0;j<n+m;j++)
    				 dp[i]=min(dp[i],d[j][i]);
    		 for(int i=1;i<(1<<n);i++){
    			 for(int j=i&(i-1);j;j=i&(j-1))
    				 dp[i]=min(dp[i],dp[j]+dp[i-j]);
    		 }
    		 cout<<dp[(1<<n)-1]<<endl;
    	 }
         return 0;
    }
    


  • 相关阅读:
    php练习题之裁判打分
    OPENSUSE:安装方式
    openSUSE:下载帮助
    安装mysql时出现HTTP&nbsp;500&nbsp;内部服务…
    关于wamp启动是80端口被占用的问题…
    推荐15款好用的JS开发工具
    u盘美化
    wordpress怎么修改地址栏小图标
    显示桌面图标不见了
    站长必备的131个高权重外链库(转…
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/5048726.html
Copyright © 2011-2022 走看看