zoukankan      html  css  js  c++  java
  • HDU 1086:You can Solve a Geometry Problem too

    You can Solve a Geometry Problem too

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6997    Accepted Submission(s): 3385


    Problem Description
    Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
    Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

    Note:
    You can assume that two segments would not intersect at more than one point. 
     

    Input
    Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
    A test case starting with 0 terminates the input and this test case is not to be processed.
     

    Output
    For each case, print the number of intersections, and one line one case.
     

    Sample Input
    2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
     

    Sample Output
    1 3
    这是一道几何题。 就是在于你是否会推断两条直线直接是否有交点的方法。

    剩下就非常easy了。

    推断AB和CD两线段是否有交点:
    同一时候满足两个条件:('x'表示叉积)
    1.C点D点分别在AB的两側.(向量(ABxAC)*(ABxAD)<=0)
    2.A点和B点分别在CD两側.(向量(CDxCA)*(CDxCB)<=0)
    </pre><pre name="code" class="cpp">
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<cmath>
    
    using namespace std;
    
    struct Node
    {
        double x1, y1, x2, y2;
    }point[105];
    int n;
    
    double work(double x1, double y1, double x2, double y2)
    {
        return x1 * y2 - x2 * y1;
    }
    
    bool judge(int i, int j)
    {
        double a = work(point[i].x1 - point[j].x1, point[i].y1 - point[j].y1, point[j].x2 - point[j].x1, point[j].y2 - point[j].y1);
        double c = work(point[j].x2 - point[i].x1, point[j].y2 - point[i].y1, point[i].x2 - point[i].x1, point[i].y2 - point[i].y1);
        double b = work(point[i].x2 - point[j].x1, point[i].y2 - point[j].y1, point[j].x2 - point[j].x1, point[j].y2 - point[j].y1);
        double d = work(point[j].x1 - point[i].x1, point[j].y1 - point[i].y1, point[i].x2 - point[i].x1, point[i].y2 - point[i].y1);
        a = a * b;
        c = c * d;
        if(a <= 0 && c <= 0)
            return true;
        return false;
    }
    
    int main()
    {
        while(cin >> n, n){
            for(int i = 0; i < n; i++)
                cin >> point[i].x1 >> point[i].y1 >> point[i].x2 >> point[i].y2;
            int count = 0;
            for(int i = 0; i < n; i++)
            {
                for(int j = i + 1; j < n; j++)
                    if(judge(i, j))
                        count++;
            }
            cout << count << endl;
     }
        return 0;
    }
    




  • 相关阅读:
    csp-s测试41 T2 影子
    模拟测试15 T3:rps (概率期望, 神*DP)
    考试沙币错误
    测试40
    水管局长 Lct
    测试32:chemistry
    测试35:抽卡
    模拟30,树
    考试策略&&模拟30经验总结:
    模拟测试28
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/5059561.html
Copyright © 2011-2022 走看看