zoukankan      html  css  js  c++  java
  • [ACM] POJ 3254 Corn Fields(状态压缩)

    Corn Fields
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 8062   Accepted: 4295

    Description

    Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

    Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

    Input

    Line 1: Two space-separated integers: M and N
    Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

    Output

    Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

    Sample Input

    2 3
    1 1 1
    0 1 0

    Sample Output

    9

    Hint

    Number the squares as follows:
    1 2 3
      4  

    There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

    Source

    解题思路:

    题意为有n行m列的长方形,分成n*m个格子,每一个格子标记为0或1,在这些格子里面放牛,当中1代表该格子能够放牛,0代表不能放牛,且相邻的两个格子不能同一时候有牛。问总的方案数。

    思想为状态压缩。把每一行放牛的状态看作一个二进制数,dp[i][j]表示第i行状态为j时前i行共同拥有的方案数。

    代码:

    #include <iostream>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    const int mod=100000000;
    const int maxn=12;
    int dp[maxn+1][(1<<maxn)+1];
    int num[maxn+1];
    int n,m;
    
    bool check(int i,int x)//检查第i行出现状态x是否合法
    {
        if((x&num[i])!=x)//非常巧妙,推断第i行出现的状态x是否合法,为什么这么写。由于0的地方不能放牛。
        //合法状态与原始状态0位且为0,原始状态1位的地方与合法状态相应位且都等于合法状态位上的数字
            return 0;
        if(x&(x>>1)||x&(x<<1))//不能有相邻的两个1
            return 0;
        return 1;
    }
    
    int main()
    {
        cin>>n>>m;
        int x;
        memset(num,0,sizeof(num));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            cin>>x;
            if(x)
                num[i]=num[i]|(1<<(j-1));//把每一行的状态保存到num[i]中去
        }
        int Max=(1<<m);
        dp[0][0]=1;//注意这一句啊!

    for(int i=1;i<=n;i++)//枚举每一行 { for(int j=0;j<Max;j++) { if(!check(i,j)) continue; for(int k=0;k<Max;k++) if((j&k)==0) { dp[i][j]+=dp[i-1][k]; if(dp[i][j]>=mod) dp[i][j]%=mod; } } } int ans=0; for(int i=0;i<Max;i++) { ans+=dp[n][i]; if(ans>=mod) ans%=mod; } cout<<ans; return 0; }


     

  • 相关阅读:
    spring @component的作用
    Spring 开启Annotation <context:annotation-config> 和 <context:component-scan>诠释及区别
    servlet中实现页面跳转return “r:”和return “f:
    MyEclipse中SVN的使用方法 此博文包含图片 (2012-04-19 12:18:35)
    MyEclipse使用总结——MyEclipse10安装SVN插件
    javaweb学习总结(九)—— 通过Servlet生成验证码图片
    Spring-springmvc-mybatis整合
    MyBatis连接SQLServer数据库
    mybatis入门基础(二)----原始dao的开发和mapper代理开发
    MyBatis入门基础(一)
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/5128386.html
Copyright © 2011-2022 走看看