zoukankan      html  css  js  c++  java
  • hdu 1063 Exponentiation 大数

    Problem Description
    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
     

    Input
    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
     

    Output
    The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
     

    Sample Input
    95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
     

    Sample Output
    548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 要求的是一个大数a的n次方 只是还有几个条件。比方例二。小数点前为0要删除。 代码:
    import java.math.BigDecimal;
    import java.util.Scanner;
    public class Main{
    	public static void main(String[] srgs)
    	{
    		Scanner cin =new Scanner(System.in);
    		BigDecimal a,s;
    		int i,n;
    		while(cin.hasNext())
    		{
    			a=cin.nextBigDecimal();
    			n=cin.nextInt();
    			s=a;
    			for(i=1;i<n;i++)
    				s=s.multiply(a);
    			s=s.stripTrailingZeros();     //去掉末尾所以的0
    			String ss=s.toPlainString();  //不准用科学计数的形式输出(e)。
    			if(ss.charAt(0)=='0')         //推断ss第0位是否为0
    			{
    				ss=ss.substring(1);       //从第一位截取
    			}
    			System.out.println(ss);
    		}		
    	}
    }
    





  • 相关阅读:
    C#打造51CTO自动签到服务领取无忧币之开篇
    Windows8开发实战之文本布局
    设计模式之抽像工厂
    PDM只显示表名称不显示列表名称
    JS 判断中英文字符长度
    C#操作剪贴板实现复制粘贴
    Chrome控制台设置浏览器Cookie
    通过Mysql查询分析器 建库建表语句
    推荐两个VS开发工具插件
    C#经典机试题(猫叫)
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/5171042.html
Copyright © 2011-2022 走看看