zoukankan      html  css  js  c++  java
  • HDU-1039-Easier Done Than Said?(Java && 没用正則表達式是我的遗憾.....)

    Easier Done Than Said?

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9845    Accepted Submission(s): 4784


    Problem Description
    Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

    FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

    It must contain at least one vowel.

    It cannot contain three consecutive vowels or three consecutive consonants.

    It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

    (For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
     

    Input
    The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
     

    Output
    For each password, output whether or not it is acceptable, using the precise format shown in the example.
     

    Sample Input
    a tv ptoui bontres zoggax wiinq eep houctuh end
     

    Sample Output
    <a> is acceptable. <tv> is not acceptable. <ptoui> is not acceptable. <bontres> is not acceptable. <zoggax> is not acceptable. <wiinq> is not acceptable. <eep> is acceptable. <houctuh> is acceptable.
     

    Source




     

    Recommend
    We have carefully selected several similar problems for you:  1062 1073 1043 1088 1113 


    题目说了非常多废话。说什么设置password是什么复杂的事情啦,设置过于简单也不行。没有规律又不好记忆,总之它的意思是说,你要满足它设置password的三个条件,满足则给你acceptable否则给你not acceptable。(三个条件在凝视里面......)

    由于题目过于水。并且英文也较好理解(题意还是比較清晰明了的),这里不做过多解释,Java水过......

    import java.io.*;
    import java.util.*;
    
    public class Main
    {
    
    	public static void main(String[] args)
    	{
    		// TODO Auto-generated method stub
    		Scanner input = new Scanner(System.in);
    		while (input.hasNext())
    		{
    			boolean flag1 = false, flag2 = true, flag3 = true;
    			String str = input.next();
    			if (str.endsWith("end"))
    				break;
    			char c[] = str.toCharArray();
    
    			// 第一个条件:必须包括至少一个元音字母
    			for (int i = 0; i < c.length; i++)
    			{
    				if (c[i] == 'a' || c[i] == 'e' || c[i] == 'i' || c[i] == 'o'
    						|| c[i] == 'u')
    				{
    					flag1 = true;
    					break;
    				}
    			}
    
    			// 第二个条件:不能包括三个连续的元音字母或者三个连续的辅音字母
    			int a = 0, b = 0;
    			for (int i = 0; i < c.length; i++)
    			{
    				if (c[i] == 'a' || c[i] == 'e' || c[i] == 'i' || c[i] == 'o'
    						|| c[i] == 'u')
    				{
    					a++;
    					if (a >= 3)
    					{
    						flag2 = false;
    					}
    					b = 0;
    				} 
    				else
    				{
    					b++;
    					if (b >= 3)
    					{
    						flag2 = false;
    					}
    					a = 0;
    				}
    			}
    
    			// 第三个条件:不能包括两个连续同样的字母,除了'ee'和'oo'这两种情况除外
    			int i, j = 0;
    			for (i = 1; i < c.length; i++, j++)
    			{
    				if (c[i] == c[j])
    				{
    					if (c[i] == 'e' || c[i] == 'o')
    						continue;
    					else
    					{
    						flag3 = false;
    						break;
    					}
    				}
    			}
    
    			if (flag1 && flag2 && flag3)
    			{
    				System.out.println("<" + str + "> is acceptable.");
    			} 
    			else
    			{
    				System.out.println("<" + str + "> is not acceptable.");
    			}
    
    		}
    	}
    
    }
    


    另外围观王维大牛正則表達式Pattern和Matcher(本来想用这题来练正則表達式的.....可是我还是没搞懂啊再见

    import java.util.Scanner;
    import java.util.regex.Matcher;
    import java.util.regex.Pattern;
    
    public class Main {
    	public static void main(String[] args) throws Exception {
    		Scanner cin = new Scanner(System.in);
    		while (cin.hasNext()) {
    			String str = cin.next();
    			if(str.equals("end"))
    				break;
    			Pattern p1 = Pattern.compile("[aeiou]{3}|[^aeiou]{3}");
    			Pattern p2 = Pattern.compile("([a-df-np-z])\1");
    			Pattern p3 = Pattern.compile("[aeiou]+");
    			Matcher m = p1.matcher(str);
    			boolean flag = false;
    			if(!m.find())
    			{
    				m = p2.matcher(str);
    				if(!m.find())
    				{
    					m = p3.matcher(str);
    					if(m.find())
    						flag = true;
    				}
    			}
    			if(flag)
    				System.out.println("<"+str+"> is acceptable.");
    			else
    				System.out.println("<"+str+"> is not acceptable.");
    		}
    		cin.close();
    	}
    }



     

  • 相关阅读:
    B轮公司技术问题列表(转)
    mysql函数之截取字符串
    谁才是真正的水果之王
    Mysql几种索引方式的区别及适用情况 (转)
    web安全之攻击
    css学习之样式层级和权重
    mysql中engine=innodb和engine=myisam的区别(转)
    mysql 创建表格 AUTO_INCREMENT
    mysql数据表的字段操作
    navicate使用小技巧
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/5184897.html
Copyright © 2011-2022 走看看