zoukankan      html  css  js  c++  java
  • HDOJ 5184 Brackets 卡特兰数扩展


    既求从点(0,0)仅仅能向上或者向右而且不穿越y=x到达点(a,b)有多少总走法...

    公式: C(a+b,min(a,b))-C(a+b,min(a,b)-1)  /// 

    折纸法证明卡特兰数: http://blog.sina.com.cn/s/blog_6917f47301010cno.html


    Brackets

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 506    Accepted Submission(s): 120


    Problem Description
    We give the following inductive definition of a “regular brackets” sequence:
    ● the empty sequence is a regular brackets sequence,
    ● if s is a regular brackets sequence, then (s) are regular brackets sequences, and
    ● if a and b are regular brackets sequences, then ab is a regular brackets sequence.
    ● no other sequence is a regular brackets sequence

    For instance, all of the following character sequences are regular brackets sequences:
    (), (()), ()(), ()(())
    while the following character sequences are not:
    (, ), )(, ((), ((()

    Now we want to construct a regular brackets sequence of length n, how many regular brackets sequences we can get when the front several brackets are given already.
     

    Input
    Multi test cases (about 2000), every case occupies two lines.
    The first line contains an integer n.
    Then second line contains a string str which indicates the front several brackets.

    Please process to the end of file.

    [Technical Specification]
    1n1000000
    str contains only '(' and ')' and length of str is larger than 0 and no more than n.
     

    Output
    For each case。output answer % 1000000007 in a single line.
     

    Sample Input
    4 () 4 ( 6 ()
     

    Sample Output
    1 2 2
    Hint
    For the first case the only regular sequence is ()(). For the second case regular sequences are (()) and ()(). For the third case regular sequences are ()()() and ()(()).
     



    /* ***********************************************
    Author        :CKboss
    Created Time  :2015年03月18日 星期三 20时10分21秒
    File Name     :HDOJ5184.cpp
    ************************************************ */
    
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <string>
    #include <cmath>
    #include <cstdlib>
    #include <vector>
    #include <queue>
    #include <set>
    #include <map>
    
    using namespace std;
    
    typedef long long int LL;
    
    const int maxn=1001000;
    const LL mod=1000000007LL;
    
    int n,len;
    char str[maxn];
    
    LL inv[maxn];
    LL jc[maxn],jcv[maxn];
    
    void init()
    {
    	inv[1]=1; jc[0]=1; jcv[0]=1;
    	jc[1]=1; jcv[1]=1;
    
    	for(int i=2;i<maxn;i++)
    	{
    		inv[i]=inv[mod%i]*(mod-mod/i)%mod;
    		jc[i]=(jc[i-1]*i)%mod;
    		jcv[i]=(jcv[i-1]*inv[i])%mod;
    	}
    }
    
    LL COMB(LL n,LL m)
    {
    	if(m<0||m>n) return 0LL;
    	if(m==0||m==n) return 1LL;
    	LL ret=((jc[n]*jcv[n-m])%mod*jcv[m])%mod;
    	return ret;
    }
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
    
    	init();
    	while(scanf("%d",&n)!=EOF)
    	{
    		scanf("%s",str);
    		len=strlen(str);
    
    		bool flag=true;
    		if(n%2==1) flag=false;
    		int left=0,right=0;
    		for(int i=0;i<len&&flag;i++)
    		{
    			if(str[i]=='(') left++;
    			else if(str[i]==')') right++;
    			if(left>=right) continue;
    			else flag=false;
    		}
    		if(flag==false) { puts("0"); continue; }
    
    		int a=n/2-left; /// remain left
    		int b=n/2-right; /// remain right
    
    		if(b>a) swap(a,b);
    		LL ans = (COMB(a+b,b)-COMB(a+b,b-1)+mod)%mod;
    		cout<<ans<<endl;
    	}
        
        return 0;
    }
    


  • 相关阅读:
    Python实例 包机制
    Python实例 类和继承
    python实例 文件处理
    python实例 异常处理
    配置 Apache+php多端口多站点(转载)
    C#中Delegate和Event以及它们的区别(转载)
    LINQ to SQL更新数据库操作(转载)
    创业公司如何实施敏捷开发(转)
    利用ps橡皮擦工具快速抠图
    XP win2003系统 微软雅黑字体的使用方法
  • 原文地址:https://www.cnblogs.com/mengfanrong/p/5262097.html
Copyright © 2011-2022 走看看