zoukankan      html  css  js  c++  java
  • POJ 2485 Highways 最小生成树 (Kruskal)

    Description

    The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

    Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

    The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

    Input

    The first line of input is an integer T, which tells how many test cases followed.
    The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

    Output

    For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

    Sample Input

    1
    
    3
    0 990 692
    990 0 179
    692 179 0

    Sample Output

    692
    
    题意: 先输入T,有T组数据。再输入有N个点。N行N列 每一个数据代表I点到J点的距离。求完毕一个 最小生成树种 的  最大边。

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    #define q 505
    int fa[q];
    int map[q][q];
    struct node{
    	int x,y,l;
    }q[q*q/2];
    int find(int x)
    {
    	return x==fa[x]?

    x:find(fa[x]); } int cmp(node a,node b) { return a.l<b.l; } int main() { int k,t,n,i,j,max1; scanf("%d",&t); while(t--) { max1=0; k=0; scanf("%d",&n); for(i=1;i<=n;i++) { fa[i]=i; for(j=1;j<=n;j++) { scanf("%d",&map[i][j]); if(i<j) // 优化:去掉重边还有中间的0 { k++; //不知道有多少边。这样统计 q[k].x=i; q[k].y=j; q[k].l=map[i][j]; } } } sort(q+1,q+1+k,cmp); //依据每条边的距离排序 for(i=1;i<=k;i++) { if(fa[find(q[i].x)]!=fa[find(q[i].y)]) //并查集思想。。

    { fa[find(q[i].x)]=find(q[i].y); if(q[i].l>max1) max1=q[i].l; } } cout<<max1<<endl; } return 0; }


    Kruskal 模板。。


  • 相关阅读:
    python学习----8.28---单例模式,网络编程
    python学习-----8.27----异常处理,元类
    python学习--8.23
    python学习-----8.22--classmethod和staticmethod
    Python学习---8.21组合,多态,封装
    python学习----8.20面向对象---继承与派生
    Python学习----8.17--面向对象编程
    python成长之旅 一
    python java php语言之间的对比
    python成长之旅
  • 原文地址:https://www.cnblogs.com/mfmdaoyou/p/7143250.html
Copyright © 2011-2022 走看看