zoukankan      html  css  js  c++  java
  • POJ

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about?

    That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    题意:求插入完后顺序

    思路:我们能够反着想,最后一个插入的时候。假如值是0,那么他一定能找到位置。但这个0我们须要这么理解:他希望的是他的前面是0个空位,假设这么理解的话,那么我们倒序插入就会得到结果

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>
    #define lson(x) ((x) << 1)
    #define rson(x) ((x) << 1 | 1)
    using namespace std;
    const int maxn = 200005;
    
    struct Node {
    	int pos, val;
    } node[maxn<<2];
    int Index[maxn<<2], num[maxn<<2];
    
    void update(int l, int r, int pos, int k, int val) {
    	if (l == r) {
    		num[pos]++;
    		Index[l] = val;
    		return;
    	}
    	int m = l + r >> 1;
    	int tmp = m - l + 1 - num[lson(pos)];
    	if (tmp > k)
    		update(l, m, lson(pos), k, val);
    	else update(m+1, r, rson(pos), k-tmp, val);
    	num[pos] = num[lson(pos)] + num[rson(pos)];
    }
    
    int main() {
    	int n;
    	while (scanf("%d", &n) != EOF) {
    		memset(num, 0, sizeof(num));
    		for (int i = 1; i <= n; i++) 
    			scanf("%d%d", &node[i].pos, &node[i].val);
    		for (int i = n; i >= 1; i--)
    			update(1, n, 1, node[i].pos, node[i].val);
    		for (int i = 1; i <= n; i++)
    			printf("%d%c", Index[i], i==n?'
    ':' ');
    	}
    	return 0;
    }



    版权声明:本文博客原创文章,博客,未经同意,不得转载。

  • 相关阅读:
    多线程中lock用法
    跨域使用Proxy page或Cross Frame
    new 操作符所做的事情
    跨域使用js文件
    跨域使用window.name
    TFS 映射错误( is already mapped in workspace)解决办法
    跨域使用JSONP
    jquery加载页面中的部分内容
    CQRS架构案例Tiny Library CQRS详解:AOP拦截与异常处理
    面向领域驱动架构的查询实现方式
  • 原文地址:https://www.cnblogs.com/mfrbuaa/p/4644718.html
Copyright © 2011-2022 走看看