zoukankan      html  css  js  c++  java
  • [2011山东ACM省赛] Identifiers(模拟)

    Identifiers

    Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

    题目描写叙述

     Identifier is an important concept in the C programming language. Identifiers provide names for several language elements, such as functions, variables, labels, etc.

    An identifier is a sequence of characters. A valid identifier can contain only upper and lower case alphabetic characters, underscore and digits, and must begin with an alphabetic character or an underscore. Given a list of chararcter sequences, write a program to check if they are valid identifiers.

    输入

     The first line of the input contains one integer, N, indicating the number of strings in the input. N lines follow, each of which contains at least one and no more than 100 characters. (only upper and lower case alphabetic characters, digits, underscore (" "), hyphen ("-"), period ("."), comma (","), colon (":"), semicolon (";"), exclamation mark ("!"), question mark ("?"), single and double quotation marks, parentheses, white space and square brackets may appear in the character sequences.)

    输出

    For each of the N lines, output "Yes" (without quote marks) if the character sequence contained in that line make a valid identifier; output "No" (without quote marks) otherwise.

    演示样例输入

    7
    ValidIdentifier
    valid_identifier
    valid_identifier
    0 invalid identifier
    1234567
    invalid identifier
    adefhklmruvwxyz12356790 -.,:;!?'"()[]ABCDGIJLMQRSTVWXYZ

    演示样例输出

    Yes
    Yes
    Yes
    No
    No
    No
    No

    提示

     

    来源

    山东省第二届ACM大学生程序设计竞赛

    解题思路:

    推断是否输入的字符串为合法标识符。

    代码:

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <ctype.h>
    using namespace std;
    string str[1000];
    int main()
    {
        int n;cin>>n;
        getchar();//必须得加这个,吸收空格,否则后面用getline会出错
        for(int i=1;i<=n;i++)
        {
            getline(cin,str[i]);
            bool ok=1;
            int len=str[i].length();
            if(!isalpha(str[i][0])&&str[i][0]!='_')//首字母不是字母也不是下划线
            {
                cout<<"No"<<endl;
                continue;
            }
            for(int j=0;j<len;j++)
            {
                if(!isdigit(str[i][j])&&!isalpha(str[i][j])&&str[i][j]!='_')//不符合要求
                {
                    ok=0;
                    break;
                }
            }
            if(ok)
                cout<<"Yes"<<endl;
            else
                cout<<"No"<<endl;
        }
        return 0;
    }
    


     

    版权声明:本文博客原创文章,博客,未经同意,不得转载。

  • 相关阅读:
    [转]Invalid postback or callback argument
    DOS之用变量存储输出
    [转]Invalid character in a Base64 string
    [转]100 个强大的 CSS 制作菜单的教程
    [转]delphi的TList,TStringList,TObjectList
    面试感悟一名3年工作经验的程序员应该具备的技能
    Java编程思想重点笔记(Java开发必看)
    第一大章物理层思维导图
    第一大章1.1概论
    jmeter 正则表达式学习(二)使用实例 非墨
  • 原文地址:https://www.cnblogs.com/mfrbuaa/p/4686198.html
Copyright © 2011-2022 走看看