zoukankan      html  css  js  c++  java
  • POJ 2524 :Ubiquitous Religions

    Time Limit: 5000MS
    Memory Limit: 65536K
    Total Submissions: 23171
    Accepted: 11406

    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7
    


    额。。难道题单错了?。。

    。我一看就是并查集。

    。所以就这么水过了。。


    并查集一A水过


    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<queue>
    #include<sstream>
    #include<cmath>
    
    using namespace std;
    
    #define M 100500
    int p[M];
    int n, m;
    
    void start()
    {
        for(int i=1; i<=n; i++)
            p[i] = i;
    }
    
    int find(int x)
    {
        return p[x] == x ?

    x : p[x] = find( p[x] ); } void Kruskal(int x, int y) { int xx = find(x); int yy = find(y); if(xx!=yy) p[yy] = xx; } int main() { int cas = 0; while(scanf("%d%d", &n, &m) &&n &&m) { cas++; start(); int ans = 0; for(int i=1; i<=m; i++) { int x; int y; scanf("%d%d", &x, &y); Kruskal(x, y); } for(int i=1; i<=n; i++) { if( p[i]==i ) ans++; } printf("Case %d: %d ", cas, ans); } return 0; }







  • 相关阅读:
    MATLAB读取文件——从非常规文本文件中读取数据
    注意——CAN通信设备控制
    硬件——USB传输速度和物理接口
    STM32F4-浮点DSP库的MDK开发环境的设置
    CRC校验
    蓝牙串口使用心得
    Mysql 层级、执行顺序、执行计划分析
    讲一讲垃圾回收算法
    【转】Java中的新生代、老年代、永久代和各种GC
    工具链接
  • 原文地址:https://www.cnblogs.com/mfrbuaa/p/5078519.html
Copyright © 2011-2022 走看看