zoukankan      html  css  js  c++  java
  • [欧拉回路+手动开栈] poj 1780 Code

    题目链接:

    http://poj.org/problem?

    id=1780

    Code
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 2037   Accepted: 751

    Description

    KEY Inc., the leading company in security hardware, has developed a new kind of safe. To unlock it, you don't need a key but you are required to enter the correct n-digit code on a keypad (as if this were something new!). There are several models available, from toy safes for children (with a 2-digit code) to the military version (with a 6-digit code). 

    The safe will open as soon as the last digit of the correct code is entered. There is no "enter" key. When you enter more than n digits, only the last n digits are significant. For example (in the 4-digit version), if the correct code is 4567, and you plan to enter the digit sequence 1234567890, the door will open as soon as you press the 7 key. 

    The software to create this effect is rather simple. In the n-digit version the safe is always in one of 10n-1 internal states. The current state of the safe simply represents the last n-1 digits that have been entered. One of these states (in the example above, state 456) is marked as the unlocked state. If the safe is in the unlocked state and then the right key (in the example above, 7) is pressed, the door opens. Otherwise the safe shifts to the corresponding new state. For example, if the safe is in state 456 and then you press 8, the safe goes into state 568. 

    A trivial strategy to open the safe is to enter all possible codes one after the other. In the worst case, however, this will require n * 10n keystrokes. By choosing a good digit sequence it is possible to open the safe in at most 10n + n - 1 keystrokes. All you have to do is to find a digit sequence that contains all n-digit sequences exactly once. KEY Inc. claims that for the military version (n=6) the fastest computers available today would need billions of years to find such a sequence - but apparently they don't know what some programmers are capable of...

    Input

    The input contains several test cases. Every test case is specified by an integer n. You may assume that 1<=n<=6. The last test case is followed by a zero.

    Output

    For each test case specified by n output a line containing a sequence of 10n + n - 1 digits that contains each n-digit sequence exactly once.

    Sample Input

    1
    2
    0
    

    Sample Output

    0123456789
    00102030405060708091121314151617181922324252627282933435363738394454647484955657585966768697787988990
    

    Source

    [Submit]   [Go Back]   [Status]   [Discuss]

    题目意思:

    n位password,每位能够是0~9随意一个,求一个串,使得这个串中随意两个n位都不同样。

    解题思路:

    欧拉路径+手动开栈

    欧拉路径求法是dfs走到不能走的时候后纪录路径。然后逆序输出。

    代码:

    //#include<CSpreadSheet.h>
    
    #include<iostream>
    #include<cmath>
    #include<cstdio>
    #include<sstream>
    #include<cstdlib>
    #include<string>
    #include<string.h>
    #include<cstring>
    #include<algorithm>
    #include<vector>
    #include<map>
    #include<set>
    #include<stack>
    #include<list>
    #include<queue>
    #include<ctime>
    #include<bitset>
    #include<cmath>
    #define eps 1e-6
    #define INF 0x3f3f3f3f
    #define PI acos(-1.0)
    #define ll __int64
    #define LL long long
    #define lson l,m,(rt<<1)
    #define rson m+1,r,(rt<<1)|1
    //#define M 1000000007
    //#pragma comment(linker, "/STACK:1024000000,1024000000")
    using namespace std;
    
    #define Maxn 1000000
    int n,s;
    int List[Maxn+10],St[Maxn+10];
    char ans[Maxn+10];
    
    void solve(int cur,int M)
    {
        while(List[cur]<10)
        {
            int w=cur*10+List[cur];
            List[cur]++;
            St[++s]=w;
            cur=w%M;
        }
    }
    int main()
    {
        //freopen("in.txt","r",stdin);
       //freopen("out.txt","w",stdout);
       while(~scanf("%d",&n)&&n)
       {
           int M=pow(10.0,double(n-1));
    
           for(int i=0;i<M;i++)
                List[i]=0;
           s=0;
           int a=0;
           solve(0,M);
    
           while(s)
           {
               ans[++a]=St[s]%10+'0';
               s--;
               solve(St[s+1]/10,M);
           }
           for(int i=1;i<n;i++)
                printf("0");
           while(a)
                printf("%c",ans[a--]);
           putchar('
    ');
    
       }
        return 0;
    }
    
    



  • 相关阅读:
    document
    reg() replace
    BOM和DOM的区别
    注册表
    实现移动端通过下拉菜单栏实现pc端的导航栏
    通过ajax获取api,并且通过jquery获取自定义属性
    git的使用
    当盒子不设置width,而设置max-width遇到的问题
    CSS之position
    JavaScript之数组常用的方法
  • 原文地址:https://www.cnblogs.com/mfrbuaa/p/5146491.html
Copyright © 2011-2022 走看看