排名
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9293 Accepted Submission(s): 3453
Problem Description
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。
Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。
Sample Input
4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0
Sample Output
3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20
Hint
Huge input, scanf is recommended.
这题我做了很久,主要是考结构体排序,我开始时的方法是用自己的方法排序,结果错了,最后采用结构体排序,AC了
#include <stdio.h>
#include <iostream>
#include "algorithm"
#include <string.h>
using namespace std;
struct student{
string id;
int g=0;
};
bool cmp(const student &a,const student &b){
if (a.g == b.g)
return strcmp(a.id.c_str(),b.id.c_str()) < 0 ? 1 : 0;
else return a.g > b.g;
}
int main(){
int a;
while(scanf("%d",&a) != EOF){
if (a == 0) break;
int exam,grade;
cin>>exam>>grade;
int G[exam];
for(int i=0;i<exam;i++){
cin>>G[i];
}
int sum=0;
student std[a];
for(int i=0;i<a;i++){
cin>>std[i].id;
int j;
cin>>j;
for(int p=0;p<j;p++){
int t,te;
cin>>t;
std[i].g+=G[t-1];
}
if(std[i].g>=grade){
sum++;
}
}
cout<<sum<<endl;
int count=0,count1=0;
sort(std,std+a,cmp);
for(int i=0;i<a;i++){
if(std[i].g>=grade){
cout<<std[i].id<<" "<<std[i].g<<endl;
}
}
}
return 0;
}
strcmp(a, b) 中a , b都必须是char*型或者是常量,如果是string型可以用
string的c_str()成员函数来获得char *
如: strcmp(a.c_str(),b.c_str()); a, b为string型;