zoukankan      html  css  js  c++  java
  • Hashmat the brave warrior

    欢迎访问我的新博客:http://www.milkcu.com/blog/

    原文地址:http://www.milkcu.com/blog/archives/uva10055.html

    题目描述

    Problem A

    Hashmat the brave warrior

    Input: standard input

    Output: standard output

    Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.


    Input

    The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.

    Output

     For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

     

    Sample Input:

    10 12
    10 14
    100 200

     

    Sample Output:

    2
    4
    100
    ___________________________________________________________________________________ 
    Shahriar Manzoor
    16-12-2000

    解题思路

    注意32位整数的范围,使用无符号整数或64位整数。 
    一道非常简单的题,答案为什么总是错误的呢?
    These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army orvice versa.
    注意vice versa”,反之亦然。但是还是无法通过。
    通过多次试验,发现绝对值函数abs()竟然在<algorithm> 头文件中。

    代码实现

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    int main(void) {
    	long long a, b;
    	while(cin >> a >> b) {
    		cout << abs(b - a) << endl;
    	}
    	return 0;
    }

    (全文完)

  • 相关阅读:
    nodejs创建路由
    node,js 使用express 生成站点的命令
    Ajax异步同步原理
    jquery问题总结
    JS正则表达式
    幻灯片缓冲效果
    转:offsetParent的理解
    微信小程序左右滑动切换页面示例代码--转载
    python正则表达式
    Django笔记(番外):虚拟环境
  • 原文地址:https://www.cnblogs.com/milkcu/p/3808857.html
Copyright © 2011-2022 走看看