zoukankan      html  css  js  c++  java
  • PAT 1076. Forwards on Weibo (30)

    Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

    M[i] user_list[i]

    where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

    Then finally a positive K is given, followed by K UserID's for query.

    Output Specification:

    For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

    Sample Input:

    7 3
    3 2 3 4
    0
    2 5 6
    2 3 1
    2 3 4
    1 4
    1 5
    2 2 6
    

    Sample Output:

    4
    5
    
    /*  题目大意是: 一个微博用户发帖 根据关注他的人数 求最大可能被转载的次数 而且最多只能被间接转载m-1次
        注意:和六度空间基本相同  但这里是单向图 
    */
    #include "iostream"
    #include "queue"
    using namespace std;
    int Count;
    bool map[1001][1001] = {false};
    int n, m;
    void bfs(int x) {
        Count = 0;
        bool visited[1001] = {false};
        queue<int>q;
        q.push(x);
        visited[x] = true;
        int last = x;
        int tail;
        int level = 0;
        while (!q.empty()) {
            x = q.front();
            q.pop();
            for (int i = 1; i <= n; i++) {
                if (map[x][i] == 1 && !visited[i]) {
                    Count++;
                    visited[i] = 1;
                    tail = i;
                    q.push(i);
                }
            }
            if (last == x) {
                level++;
                last = tail;
            }
            if (level == m)
                break;
        }
    }
    int main() {
        cin >> n >> m;
        for (int i = 1; i <= n; i++) {
            int l;
            cin >> l;
            while (l--) {
                int x;
                cin >> x;
                map[x][i] = 1;
            }
        }
        int k;
        cin >> k;
        while (k--) {
            int x;
            cin >> x;
            bfs(x);
            cout << Count << endl;
        }
        return 0;
    }
  • 相关阅读:
    ALinq Dynamic 使用指南——前言
    前端与后端分离的架构实例(三)
    前端与后端分离的架构实例(二)
    启动画面QSplashScreen鼠标点击的时候不退出
    Qt组件屏蔽鼠标激活
    Qt LNK2001错误
    QtDesigner中设定一个组件位于另一个组件上方
    QToolButton设置图片
    osgearth_package切片工具切局部影像或者高程tif无法生成切片问题;切完数据集无法显示问题
    Qt输入框添加搜索按钮,以及自动补全内容
  • 原文地址:https://www.cnblogs.com/minesweeper/p/5937669.html
Copyright © 2011-2022 走看看