zoukankan      html  css  js  c++  java
  • 1003. Emergency (25)

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

    Output

    For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
    All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input

    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1
    

    Sample Output

    2 4
    /* 
      题意:求最短路的总条数 并在保证最短路的情况下  求一条最短路  路径中所有城市中的护士总人数最大。
      dijsktra的变种 想明白就好写。
     */
    #include "iostream"
    using namespace std;
    #define INF 999999
    int p[501], map[501][501], dist[501];
    int Count[501];
    int cost[501];
    int n, m, s, e;
    bool flag = 0;
    bool vis[501] = { false };
    void dijkstra() {
        int u ;
        for (int j = 0; j < n-1; j++) {
            int Min = INF;
            for (int i = 0; i < n; i++)
            {
                if (!vis[i] && dist[i] < Min) {
                    Min = dist[i];
                    u = i;
                }
            }
            if (Min < INF) 
                vis[u] = true;
            else { /* 图不连通 结束*/
                flag = 1;
                break;
            }
            for (int i = 0; i < n; i++) {
                if (!vis[i]) {
                    if (dist[i] >= dist[u] + map[u][i]) {
                        if (dist[i] == dist[u] + map[u][i]) {
                            Count[i] += Count[u];
                            if (cost[i] < cost[u] + p[i])
                                cost[i] = cost[u] + p[i];
                        }
                        else {
                            dist[i] = dist[u] + map[u][i];
                            Count[i] = Count[u];
                            cost[i] = cost[u] + p[i];
                        }
                    }
                }
            }
        }
    }
    int main() {
        cin >> n >> m >> s >> e;
        for(int i=0; i<n; i++)
            for (int j = 0; j < n; j++) {
                if (i == j)
                map[i][j] = map[j][i] = 0;
                else
                map[i][j] = map[j][i] = INF;
            }
        for (int i = 0; i < n; i++) {
            cin >> p[i];
        }
        for (int i = 0; i < m; i++) {
            int a, b, c;
            cin >> a >> b >> c;
            map[a][b] = map[b][a] = c;
        }
        for (int i = 0; i < n; i++) {
            dist[i] = map[i][s];
        }
        cost[s] = p[s];
        Count[s] = 1;
        dijkstra();
        if (flag)
            cout << 0 << " " << 0 << endl;
        else
        cout << Count[e] <<" "<< cost[e] << endl;
        return 0;
    }
  • 相关阅读:
    MOSS的权限控制很好很强大的
    infopath:InfoPath 上传多附件解决思路方法
    http://www.cnblogs.com/ahjxxy/archive/2010/08/09/1796125.html
    MOSS-批量自定义列表项权限
    ABAP中ALV导出excel表格时有个字段总是少一位,请问是什么原因?如何解决?
    SAP ABAP AT NEW 和AT END OF的用法
    ABAP 的message 的创建及使用
    Screen返回选择界面的问题
    SPELL_AMOUNT
    【ABAP内表】关于At first/ At last/ At new /At end of
  • 原文地址:https://www.cnblogs.com/minesweeper/p/6271365.html
Copyright © 2011-2022 走看看