zoukankan      html  css  js  c++  java
  • 1008. Elevator (20)

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1
    

    Sample Output:

    41

    /* water..
      理解题意就超简单- - 刚开始理解错了,以为每一个楼层就要等待5分钟- -!
    */
    #include "iostream"
    using namespace std;
    int main() {
        int n;
        int pre, now;
        cin >> n;
        pre = 0;
        int k = 1;
        int sum = 0;
        for (int i = 1; i <= n; i++) {
            cin >> now;
                if (now > pre) {
                    sum += (now - pre) * 6 + 5;
                }
                else if (now < pre) {
                    sum += (pre-now) * 4 + 5;
                }
                else {
                    sum += 5;
                }
            pre = now;
        }
        cout << sum << endl;
        return 0;
    }
  • 相关阅读:
    android 解密工具
    android打包需要的图标
    Mac 创建软链接
    历届试题 Excel地址
    算法训练 字串统计
    最长回文子串
    算法提高 P1001【大数乘法】
    算法提高 拿糖果【埃氏筛 动态规划】
    算法训练 未名湖边的烦恼
    算法提高 合并石子【动态规划】
  • 原文地址:https://www.cnblogs.com/minesweeper/p/6280381.html
Copyright © 2011-2022 走看看