zoukankan      html  css  js  c++  java
  • 1013. Battle Over Cities (25)

    It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

    For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

    Input

    Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

    Output

    For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

    Sample Input

    3 2 3
    1 2
    1 3
    1 2 3
    

    Sample Output

    1
    0
    0

    /* 求在一个连通图中去掉一个节点后 需要至少添加几条边才能使剩下的节点连通  
       1. 用dfs求区域数  减1 即可。 去掉的那个节点将其visited[i]置为1 在dfs中通过该节点连接的节点就被分隔开来了。
    */
    #include "iostream"
    #include "cstring"
    using namespace std;
    #define MAX 1001
    int map[MAX][MAX];
    int visited[MAX];
    int n, m, k;
    void dfs(int j) {
        visited[j] = 1;
        for (int i = 1; i <= n; i++) {
            if (!visited[i] && map[j][i] == 1) {
                dfs(i);
            }
        }
    }
    int main() {
        cin >> n >> m >> k;
        while (m--) {
            int a, b;
            cin >> a >> b;
            map[a][b] = map[b][a] = 1;
        }
        while (k--) {
            int num = 0;
            int l;
            cin >> l;
            memset(visited, 0, sizeof(visited));
            visited[l] = 1;
            for(int i=1; i<=n; i++)
                if (!visited[i]) {
                    dfs(i);
                    num++;
                }
                cout << num - 1 << endl;
        }
        
        return 0;
    }
    /* 
      并查集解法: O(n*e) 最差:1000 * 500000  基本都500ms左右了- - 查询的时候路径压缩 最后将近300ms..
    */
    #include "iostream"
    using namespace std;
    int father[1001];
    struct Edge {
        int x, y;
    }edge[500001];
    void Init(int n) {
        for(int i=1; i<=n; i++)
           father[i] = -1;
    }
    int find(int  x) {
        if (father[x] == -1)
            return x;
        return father[x] = find(father[x]);
    }
    int main() {
        int n, m, k;
        cin >> n >> m >> k;
        for(int i =0; i<m; i++){
            cin >> edge[i].x >> edge[i].y;
        }
        while (k--) {
            Init(n);
            int c;
            int ans = 0;
            cin >> c;
            for (int i = 0; i < m; i++) {
                if (edge[i].x != c && edge[i].y != c) {
                    int x = find(edge[i].x);
                    int y = find(edge[i].y);
                    if (x != y) {
                        father[x] = y;
                    }
                }
            }
            for (int i = 1; i <= n; i++)
                if (father[i] == -1)
                    ans++;
            cout << ans - 2 << endl;
        }
        return 0;
    }
  • 相关阅读:
    vim编辑器和bash算术运算入门
    vim编辑器
    egrep及文本处理工具
    grep与基本正则表达式
    bash脚本编程基础及配置文件
    博客开通了
    测试用例考虑因素
    地图测试点的总结
    app测试的case点(2)
    App 99.9%稳定
  • 原文地址:https://www.cnblogs.com/minesweeper/p/6296729.html
Copyright © 2011-2022 走看看