zoukankan      html  css  js  c++  java
  • BZOJ2761 [JLOI2011]不重复数字

    Time Limit: 10 Sec  Memory Limit: 128 MB
    Submit: 6950  Solved: 2652
    [Submit][Status][Discuss]

    Description

    给出N个数,要求把其中重复的去掉,只保留第一次出现的数。
    例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4。
     

    Input

    输入第一行为正整数T,表示有T组数据。
    接下来每组数据包括两行,第一行为正整数N,表示有N个数。第二行为要去重的N个正整数。
     

    Output

     
    对于每组数据,输出一行,为去重后剩下的数字,数字之间用一个空格隔开。

    Sample Input

    2
    11
    1 2 18 3 3 19 2 3 6 5 4
    6
    1 2 3 4 5 6

    Sample Output

    1 2 18 3 19 6 5 4
    1 2 3 4 5 6
     
    水题,用map记录之前是否出现过即可。
     
    #include <bits/stdc++.h>
    using namespace std;
    int T;
    int n,tmp;
    map <int,bool> a;
    int main(){
        scanf("%d",&T);
        while(T--){
            scanf("%d",&n);
            a.clear();
            scanf("%d",&tmp);
            printf("%d",tmp);
            a[tmp] = 1;
            for (int i = 2;i <= n;++i){
                scanf("%d",&tmp);
                if (!a[tmp]){
                    printf(" %d",tmp);
                    a[tmp] = 1;
                }
            }
            puts("");
        }
        return 0;
    }
  • 相关阅读:
    jvm调优
    Spring 事务
    Spring Framework入门介绍
    redis入门介绍
    Spring与SpringMVC重复扫描问题
    跨域相关问题
    Spring MVC介绍
    Servlet、Servlet容器
    获取屏幕宽高
    mybatis中比较符的写法
  • 原文地址:https://www.cnblogs.com/mizersy/p/9739897.html
Copyright © 2011-2022 走看看