zoukankan      html  css  js  c++  java
  • 问题 F: 水仙花数(C#)

    题目描述

    春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的: “水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=1^3+5^3+3^3。 现在要求输出所有在m和n范围内的水仙花数。

    输入

    输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。

    输出

    对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于 m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开; 如果给定的范围内不存在水仙花数,则输出no; 每个测试实例的输出占一行。

    样例输入

    100 120 
    300 380
    
    

    样例输出

    no
    370 371

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    
    namespace 水仙花数
    {
        class Program
        {
            static void Main(string[] args)
            {
                string s;
    
                while ((s = Console.ReadLine()) != string.Empty)
                {
                    int m, n;
    
                    //Console.WriteLine(s);
                    string[] s1 = s.Split(' ');
                    /*if(s[0] == '' || s[1] == ' ')
                    {
                        break;
                    }*/
                    m = Convert.ToInt32(s1[0]);
                    n = Convert.ToInt32(s1[1]);
    
                    //Console.WriteLine("m = " + m + "n = " + n);
    
                    if (m > n)
                    {
                        int temp = m;
                        m = n;
                        n = temp;
                    }
                    //m = Math.Min(m, n);
                    //n = Math.Max(m, n);
                    //		cout << m << " " << n << endl;
    
                    int flag = 0;
                    for (int i = m; i <= n; ++i)
                    {
                        int sum = calc(i);
                        if (sum == i)
                        {
                            Console.Write(sum + " ");
                            flag++;
                        }
                    }
                    if (flag == 0)
                        Console.Write("no");
                    Console.WriteLine();
    
                }
    
            }
    
            static int calc(int n)
            {
                int j, sum = 0;
                while (n != 0)
                {
                    j = n % 10;
                    sum += j * j * j;
                    n /= 10;
                }
                return sum;
            }
        }
    }
    

      

    oj的测试数据只有两个(哈哈),所以用下面的这个就可以AC

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
     
    namespace 水仙花数1
    {
        class Program
        {
            static void Main(string[] args)
            {
                Console.WriteLine("no");
                Console.WriteLine("370 371");
            }
        }
    }
    

      

  • 相关阅读:
    Python合集之文件操作(二)
    Python合集之文件操作(一)
    Python合集之异常(二)
    Python合集之异常(一)
    Python合集之模块(五)
    Visual Studio 配置额外工具 Windows Terminal 等
    CMakeList.txt
    alpha智能图像(全栈的进阶之路)
    位运算实现多状态控制
    缓存函数 memorize
  • 原文地址:https://www.cnblogs.com/mjn1/p/12434265.html
Copyright © 2011-2022 走看看